summaryrefslogtreecommitdiff
path: root/benchmarks/stream/files
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2001-11-06 20:17:17 +0000
committerPete Fritchman <petef@FreeBSD.org>2001-11-06 20:17:17 +0000
commit20364ec3d44993d5550a4d8b21b77a04cfd2894e (patch)
tree29d8b05b05a644cbced299fdd88ca05acc7a917b /benchmarks/stream/files
parent(Forced commit to correct the previous log) (diff)
Add stream-1.0, a synthetic benchmark program that measures sustainable
memory bandwidth PR: 27272 Submitted by: Scott Flatman <sf@dsinw.com>
Diffstat (limited to 'benchmarks/stream/files')
-rw-r--r--benchmarks/stream/files/Makefile24
-rw-r--r--benchmarks/stream/files/patch-stream_d.c13
2 files changed, 37 insertions, 0 deletions
diff --git a/benchmarks/stream/files/Makefile b/benchmarks/stream/files/Makefile
new file mode 100644
index 000000000000..c0516fcee132
--- /dev/null
+++ b/benchmarks/stream/files/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+# stream didn't come with a makefile
+
+CFLAGS+= -Wall -pedantic -ansi -pipe
+BINOWN= root
+BINGRP= wheel
+BINMODE= 0555
+INSTALLDIR= ${PREFIX}/bin
+
+# season to flavor, see the stream docs
+NSIZE= 1000000
+
+#
+all: stream_d.o second_cpu.o
+ ${CC} -o stream stream_d.o second_cpu.o -lm
+
+stream_d.o: stream_d.c
+ ${CC} ${CFLAGS} -DNSIZE=${NSIZE} -c stream_d.c
+
+second_cpu.o: second_cpu.c
+ ${CC} ${CFLAGS} -c second_cpu.c
+
+install:
+ ${INSTALL} -c -o ${BINOWN} -g ${BINGRP} -m ${BINMODE} stream ${INSTALLDIR}
diff --git a/benchmarks/stream/files/patch-stream_d.c b/benchmarks/stream/files/patch-stream_d.c
new file mode 100644
index 000000000000..e2d95b14857e
--- /dev/null
+++ b/benchmarks/stream/files/patch-stream_d.c
@@ -0,0 +1,13 @@
+$FreeBSD$
+
+--- stream_d.c.orig Tue Nov 6 15:02:21 2001
++++ stream_d.c Tue Nov 6 15:03:11 2001
+@@ -23,7 +23,7 @@
+ * that should be good to about 5% precision.
+ */
+
+-# define N 1000000
++# define N NSIZE
+ # define NTIMES 10
+ # define OFFSET 0
+