summaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2006-05-07 14:47:21 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2006-05-07 14:47:21 +0000
commit0d01beefd877fae55ff560dc302fe79fc47f8e44 (patch)
tree6662fc084d45cb84a02fa623b750f865f291b6c5 /audio
parentUpdate to 0.9.1 (diff)
Unbreak after GLib 2.10 import.
Reported by: pointyhat via kris
Diffstat (limited to 'audio')
-rw-r--r--audio/beast/Makefile2
-rw-r--r--audio/beast/files/patch-sfi_glib-extra.c21
-rw-r--r--audio/beast/files/patch-sfi_glib-extra.h11
3 files changed, 33 insertions, 1 deletions
diff --git a/audio/beast/Makefile b/audio/beast/Makefile
index 752a4aa1f6ee..213d420c6e83 100644
--- a/audio/beast/Makefile
+++ b/audio/beast/Makefile
@@ -7,7 +7,7 @@
PORTNAME= beast
PORTVERSION= 0.6.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio
MASTER_SITES= ftp://beast.gtk.org/pub/beast/v0.6/ \
http://beast.gtk.org/beast-ftp/v0.6/
diff --git a/audio/beast/files/patch-sfi_glib-extra.c b/audio/beast/files/patch-sfi_glib-extra.c
new file mode 100644
index 000000000000..c0b90f7f26bc
--- /dev/null
+++ b/audio/beast/files/patch-sfi_glib-extra.c
@@ -0,0 +1,21 @@
+--- sfi/glib-extra.c.orig Sun May 7 16:28:07 2006
++++ sfi/glib-extra.c Sun May 7 16:28:15 2006
+@@ -170,18 +170,6 @@
+ return NULL;
+ }
+
+-const gchar*
+-g_intern_string (const gchar *string)
+-{
+- return string ? g_quark_to_string (g_quark_from_string (string)) : NULL;
+-}
+-
+-const gchar*
+-g_intern_static_string (const gchar *string)
+-{
+- return string ? g_quark_to_string (g_quark_from_static_string (string)) : NULL;
+-}
+-
+ static gchar*
+ delim_concat_varargs (const gchar *first_string,
+ gchar delim,
diff --git a/audio/beast/files/patch-sfi_glib-extra.h b/audio/beast/files/patch-sfi_glib-extra.h
new file mode 100644
index 000000000000..c1aed2237337
--- /dev/null
+++ b/audio/beast/files/patch-sfi_glib-extra.h
@@ -0,0 +1,11 @@
+--- sfi/glib-extra.h.orig Sun May 7 16:28:20 2006
++++ sfi/glib-extra.h Sun May 7 16:28:31 2006
+@@ -90,8 +90,6 @@
+ gchar* g_strdup_rstrip (const gchar *string);
+ gchar* g_strdup_lstrip (const gchar *string);
+
+-const gchar* g_intern_string (const gchar *string);
+-const gchar* g_intern_static_string (const gchar *string);
+ const gchar* g_intern_strconcat (const gchar *first_string,
+ ...);
+ const gchar* g_intern_printf (const gchar *format,