summaryrefslogtreecommitdiff
path: root/audio/xmms-sapplug/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-12-27 11:05:30 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-12-27 11:05:30 +0000
commitbab2e760e444085d1659b60a019b51da2c91beec (patch)
treea7c254661dec1a5a1c71e7b6c7298740b6f71e3f /audio/xmms-sapplug/Makefile
parent- Remove not needed DOCS (diff)
Use CFLAGS_
Diffstat (limited to 'audio/xmms-sapplug/Makefile')
-rw-r--r--audio/xmms-sapplug/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/audio/xmms-sapplug/Makefile b/audio/xmms-sapplug/Makefile
index 9b5fdd2be3ba..d877eecab1aa 100644
--- a/audio/xmms-sapplug/Makefile
+++ b/audio/xmms-sapplug/Makefile
@@ -27,6 +27,9 @@ PLIST_FILES= lib/xmms/Input/libsap.so
OPTIONS_DEFINE= OPTIMIZED_CFLAGS
+CFLAGS_amd64= -fpic -DPIC
+CFLAGS_ia64= -fpic -DPIC
+
.include <bsd.port.pre.mk>
# clang can build this without -fno-exceptions
@@ -34,10 +37,6 @@ OPTIONS_DEFINE= OPTIMIZED_CFLAGS
CXXFLAGS+= -fno-exceptions
.endif
-.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
-CFLAGS+= -fpic -DPIC
-.endif
-
.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
CXXFLAGS+= -fPIC -fpic -funroll-all-loops -fno-strength-reduce \
-finline-functions -fomit-frame-pointer