summaryrefslogtreecommitdiff
path: root/audio/xmms-faad
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-14 13:52:43 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-14 13:52:43 +0000
commit27ee482f0a21e79109d280e57b493ce14671128b (patch)
tree3215f5c4d76435706c511f4861facd0220baef8c /audio/xmms-faad
parentChaSen.so requires linking libstdc++ explicitly. (diff)
- Update to 2.0 release
PR: ports/66600 Submitted by: michael johnson <ahze@ahze.net>
Diffstat (limited to 'audio/xmms-faad')
-rw-r--r--audio/xmms-faad/Makefile26
-rw-r--r--audio/xmms-faad/files/patch-plugins_xmms_src_Makefile.am18
-rw-r--r--audio/xmms-faad/files/patch-plugins_xmmsmp4_src_Makefile.am15
3 files changed, 11 insertions, 48 deletions
diff --git a/audio/xmms-faad/Makefile b/audio/xmms-faad/Makefile
index 7a4a3a4cc855..c27643e8eb0c 100644
--- a/audio/xmms-faad/Makefile
+++ b/audio/xmms-faad/Makefile
@@ -7,12 +7,11 @@
PORTNAME= faad2
PORTVERSION= 2.0
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= faac
PKGNAMEPREFIX= xmms-
-DISTNAME= ${PORTNAME}-${PORTVERSION}-rc3
MAINTAINER= dyeske@yahoo.com
COMMENT= XMMS plugin for faad
@@ -34,40 +33,37 @@ USE_GMAKE= yes
USE_LIBTOOL_VER=13
USE_REINPLACE= yes
-CONFIGURE_ARGS= --program-transform-name='' --with-mp4v2
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --with-xmms --with-mp4v2
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
DESCR= ${PORTSDIR}/audio/faad/pkg-descr
MD5_FILE= ${PORTSDIR}/audio/faad/distinfo
-PLIST_FILES= lib/xmms/Input/libaac.so \
- lib/xmms/Input/libmp4.so
+PLIST_FILES= lib/xmms/Input/libmp4.so
pre-patch: build-depends
post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|' ${WRKSRC}/plugins/xmms/src/Makefile.am
# make sure everything is prepared prior to configure stage
# pre-configure will not work since *AUTO* tools happen in-between
@cd ${WRKSRC}; ${ACLOCAL} -I ${ACLOCAL_DIR} -I .; \
${SETENV} ${SCRIPTS_ENV} ${LIBTOOLIZE} --automake
+ @${REINPLACE_CMD} -e 's|$$lt_target|$$host|' \
+ ${WRKSRC}/aclocal.m4
# CFLAGS safeness
@${FIND} ${WRKSRC} -type f -name Makefile.am | \
${XARGS} -n 5 -x \
${REINPLACE_CMD} -e \
's|-O2|${CFLAGS}|'
-post-configure:
-# sync the multiple libtool copies
- @${CP} ${WRKSRC}/libtool ${WRKSRC}/common/mp4v2/
- @${CP} ${WRKSRC}/libtool ${WRKSRC}/plugins/xmms/
- @${CP} ${WRKSRC}/libtool ${WRKSRC}/plugins/xmmsmp4/
-
do-build:
- @cd ${WRKSRC}/plugins/xmms && ${MAKE}
- @cd ${WRKSRC}/plugins/xmmsmp4 && ${MAKE}
+ @cd ${WRKSRC}/libfaad && ${MAKE}
+ @cd ${WRKSRC}/common/mp4v2 && ${MAKE}
+ @cd ${WRKSRC}/plugins/xmms/src && ${MAKE}
do-install:
- @cd ${WRKSRC}/plugins/xmms && ${MAKE} install
- @cd ${WRKSRC}/plugins/xmmsmp4 && ${MAKE} install
+ @cd ${WRKSRC}/plugins/xmms/src && ${MAKE} install
.include <bsd.port.mk>
diff --git a/audio/xmms-faad/files/patch-plugins_xmms_src_Makefile.am b/audio/xmms-faad/files/patch-plugins_xmms_src_Makefile.am
deleted file mode 100644
index 54ce5ef9f59b..000000000000
--- a/audio/xmms-faad/files/patch-plugins_xmms_src_Makefile.am
+++ /dev/null
@@ -1,18 +0,0 @@
---- plugins/xmms/src/Makefile.am.orig Thu Nov 6 06:04:13 2003
-+++ plugins/xmms/src/Makefile.am Sun Mar 14 23:57:12 2004
-@@ -1,13 +1,11 @@
- libdir = `xmms-config --input-plugin-dir`
- lib_LTLIBRARIES = libaac.la
-
--libaac_la_CFLAGS = `xmms-config --cflags` `$GTK_CONFIG --cflags` -Wall \
-+libaac_la_CFLAGS = `xmms-config --cflags` `${GTK_CONFIG} --cflags` ${CFLAGS} \
- -I$(top_builddir)/include
-
--libaac_la_LIBADD = $(top_builddir)/libfaad/libfaad.la
--
- libaac_la_LDFLAGS = -module -avoid-version `xmms-config --libs` \
-- `$GTK_CONFIG --libs` -lpthread -lz -lid3 -lstdc++
-+ `${GTK_CONFIG} --libs` -lfaad -lz -lid3 -lstdc++
- libaac_la_SOURCES = libaac.c id3.cpp dialog_gtk1.c aac_utils.c \
- aac_utils.h
-
diff --git a/audio/xmms-faad/files/patch-plugins_xmmsmp4_src_Makefile.am b/audio/xmms-faad/files/patch-plugins_xmmsmp4_src_Makefile.am
deleted file mode 100644
index 130e50965614..000000000000
--- a/audio/xmms-faad/files/patch-plugins_xmmsmp4_src_Makefile.am
+++ /dev/null
@@ -1,15 +0,0 @@
---- plugins/xmmsmp4/src/Makefile.am.orig Thu Nov 6 06:04:14 2003
-+++ plugins/xmmsmp4/src/Makefile.am Sun Mar 14 23:57:41 2004
-@@ -3,10 +3,8 @@
- lib_LTLIBRARIES = libmp4.la
- libmp4_la_CFLAGS = -I$(top_builddir)/common/mp4v2 \
- -I$(top_builddir)/include \
-- `xmms-config --cflags` -DHAVE_GLIB_H=1
-+ `xmms-config --cflags` ${CFLAGS} -DHAVE_GLIB_H=1
-
--libmp4_la_LDFLAGS = -module -avoid-version `xmms-config --libs` -lpthread -lstdc++
--
--libmp4_la_LIBADD = $(top_builddir)/libfaad/libfaad.la $(top_builddir)/common/mp4v2/libmp4v2.la
-+libmp4_la_LDFLAGS = -module -avoid-version `xmms-config --libs` -lfaad -lstdc++
-
- libmp4_la_SOURCES = libmp4.c libmp4_utils.c libmp4_utils.h