summaryrefslogtreecommitdiff
path: root/audio/xamp/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-05-29 22:07:05 +0000
committerWill Andrews <will@FreeBSD.org>2000-05-29 22:07:05 +0000
commit58e4d46002fb4acbd1b2a79510b306489ec9c8e8 (patch)
treeae3e9214d0efe3137dedf6b99c1bcca70654da51 /audio/xamp/Makefile
parentUpdate to 3.04. Remove MAINTAINER as his email address is bouncing. (diff)
Update to 0.8.10. Add skin data, WWW: to pkg/DESCR.
PR: 18882 Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp>
Diffstat (limited to 'audio/xamp/Makefile')
-rw-r--r--audio/xamp/Makefile22
1 files changed, 15 insertions, 7 deletions
diff --git a/audio/xamp/Makefile b/audio/xamp/Makefile
index aecf3bc36ed3..c1d1b14aeb57 100644
--- a/audio/xamp/Makefile
+++ b/audio/xamp/Makefile
@@ -6,24 +6,32 @@
#
PORTNAME= xamp
-PORTVERSION= 0.8.7
+PORTVERSION= 0.8.10
CATEGORIES= audio
-MASTER_SITES= ftp://ftp.simcb.ru/pub/unix/x11/
-DISTFILES= xamp-0.8-7.tgz
+MASTER_SITES= http://andrej.co.ru/~andrej/programs/xamp/ \
+ http://andrej.co.ru/~andrej/programs/xamp/backs/
+DISTFILES= ${PORTNAME}-0.8-10.tgz ${SKIN_DATA}
MAINTAINER= ports@FreeBSD.org
+WRKSRC= ${WRKDIR}/${PORTNAME}-0.8/${PORTNAME}-0.8g/
+DIST_SUBDIR= xamp
USE_QT= yes
-
-WRKSRC= ${WRKDIR}/xamp-0.8/xamp-0.8
-GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
-
+GNU_CONFIGURE= yes
MAN1= xamp.1
+SKIN_DATA= bfamp.tar.gz chrome.tar.gz mmxamp.tar.gz
+SKIN_DIR= ${PREFIX}/lib/X11/xamp
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xamp ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/xamp.1 ${PREFIX}/man/man1
+ @${MKDIR} ${SKIN_DIR}/bfamp-xamp
+ ${INSTALL_DATA} ${WRKDIR}/bfamp-xamp/*.bmp ${SKIN_DIR}/bfamp-xamp
+ @${MKDIR} ${SKIN_DIR}/chrome-xamp
+ ${INSTALL_DATA} ${WRKDIR}/chrome-xamp/*.bmp ${SKIN_DIR}/chrome-xamp
+ @${MKDIR} ${SKIN_DIR}/mmxxamp-xamp
+ ${INSTALL_DATA} ${WRKDIR}/mmxxamp-xamp/*.bmp ${SKIN_DIR}/mmxxamp-xamp
.include <bsd.port.mk>