summaryrefslogtreecommitdiff
path: root/audio/wavpack/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2005-07-06 11:29:13 +0000
committerKoop Mast <kwm@FreeBSD.org>2005-07-06 11:29:13 +0000
commit84641a60c1c4940d3bd4764affb8f35747cbb82b (patch)
tree50f6387f47f85f38d76e23b313f79f0a71bc4c6c /audio/wavpack/Makefile
parentForgot to commit this earlier. Now the koffice-i18n ports should work, too. (diff)
Add wavpack.
Wavepack is a completely open audio compression format providing lossless, high-quality lossy, and a unique hybrid compression mode. In the default lossless mode no original information is lost, so there is no change of degradation. Compression in this mode is between 30% an 70%. For more info see the website http://www.wavpack.com
Diffstat (limited to 'audio/wavpack/Makefile')
-rw-r--r--audio/wavpack/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/audio/wavpack/Makefile b/audio/wavpack/Makefile
new file mode 100644
index 000000000000..afe1a8a45156
--- /dev/null
+++ b/audio/wavpack/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: wavpack
+# Date created: Fri Jun 24 20:30:04 CEST 2005
+# Whom: Koop Mast <kwm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wavpack
+PORTVERSION= 4.2
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= kwm
+
+MAINTAINER= kwm@FreeBSD.org
+COMMENT= Compress (and restore) both 16 and 24-bit audio files in .wav format
+
+USE_LIBTOOL_VER=15
+USE_BZIP2= yes
+USE_REINPLACE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+INSTALLS_SHLIB= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|libdir)/pkgconfig|prefix)/libdata/pkgconfig|g' \
+ ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>