summaryrefslogtreecommitdiff
path: root/audio/splaytk/Makefile
diff options
context:
space:
mode:
authorMatthew Hunt <mph@FreeBSD.org>1998-04-24 02:33:35 +0000
committerMatthew Hunt <mph@FreeBSD.org>1998-04-24 02:33:35 +0000
commitf427f1053a5eca66c38b0b02146cf1cca1da2737 (patch)
treeff0893484d843d1dd507c886375ddc1de42ac541 /audio/splaytk/Makefile
parentActivate xothello, and add it to LEGAL as a possible trademark (diff)
Import of splaytk, a Tcl/Tk front-end to the splay mp3 player.
PR: 6352 Submitted by: Brett Taylor <brett@peloton.physics.montana.edu>
Diffstat (limited to 'audio/splaytk/Makefile')
-rw-r--r--audio/splaytk/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/audio/splaytk/Makefile b/audio/splaytk/Makefile
new file mode 100644
index 000000000000..98cc35a804ec
--- /dev/null
+++ b/audio/splaytk/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: splaytk
+# Version required: 2.0
+# Date created: 19 Apr 1998
+# Whom: brett@peloton.physics.montana.edu
+#
+# $Id:$
+#
+
+DISTNAME= splaytk-2.0
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR= apps/sound/players
+
+MAINTAINER= brett@peloton.physics.montana.edu
+
+RUN_DEPENDS= splay:${PORTSDIR}/audio/splay \
+ wish8.0:${PORTSDIR}/x11/tk80
+
+WRKSRC= ${WRKDIR}/splay-tk-2.0
+
+NO_BUILD= yes
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/splay-tk.tcl ${PREFIX}/bin/splay-tk
+ @${MKDIR} ${PREFIX}/lib/splay-tk
+ @${INSTALL_DATA} ${WRKSRC}/*.xbm ${PREFIX}/lib/splay-tk
+ @${INSTALL_DATA} ${WRKSRC}/splay-tk.gif ${PREFIX}/lib/splay-tk
+
+.include <bsd.port.mk>