summaryrefslogtreecommitdiff
path: root/audio/sphinx/Makefile
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2002-02-12 07:31:26 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2002-02-12 07:31:26 +0000
commit0f022ae0d9675beec3216f9c994c8cd17144ea3c (patch)
treebd7196be1bf56d80f559a40ee464c745f75399a7 /audio/sphinx/Makefile
parentMark as forbidden: this version should have 'GIF comment vulnerability' (diff)
Use <stdlib.h> instead of deprecated <malloc.h>.
Update to sphinx2-0.4.
Diffstat (limited to 'audio/sphinx/Makefile')
-rw-r--r--audio/sphinx/Makefile20
1 files changed, 16 insertions, 4 deletions
diff --git a/audio/sphinx/Makefile b/audio/sphinx/Makefile
index bffbe62496f7..75e06b21544f 100644
--- a/audio/sphinx/Makefile
+++ b/audio/sphinx/Makefile
@@ -6,21 +6,33 @@
#
PORTNAME= sphinx
-PORTVERSION= 2.0.2
+PORTVERSION= 2.0.4
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= cmusphinx
-DISTNAME= sphinx2-0.2
+DISTNAME= sphinx2-0.4
MAINTAINER= trevor@FreeBSD.org
-BROKEN= "seems broken for newpcm"
-
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
+PKGMESSAGE= ${WRKDIR}/pkg-message
USE_GMAKE= yes
# contains i386 sound code
ONLY_FOR_ARCHS= i386
+post-patch:
+ ${FIND} ${WRKSRC} -type f -exec ${PERL} -pi -e \
+ "s:<malloc.h>:<stdlib.h>:g" {} \;
+
+post-build:
+ ${ECHO_CMD} "*** WARNING ***" > ${PKGMESSAGE}
+ ${ECHO_CMD} "The sphinx 2 port/package has not had" >> ${PKGMESSAGE}
+ ${ECHO_CMD} "proper testing or source review by the" >> ${PKGMESSAGE}
+ ${ECHO_CMD} "FreeBSD maintainer." >> ${PKGMESSAGE}
+
+pre-install:
+ ${CAT} ${PKGMESSAGE}
+
.include <bsd.port.mk>