summaryrefslogtreecommitdiff
path: root/audio/slimserver-dynamictransition/Makefile
diff options
context:
space:
mode:
authorTim Bishop <tdb@FreeBSD.org>2006-12-15 15:09:10 +0000
committerTim Bishop <tdb@FreeBSD.org>2006-12-15 15:09:10 +0000
commitc3700b53fcd775c92cf3fd7540daffc0c246ecf3 (patch)
treee14a4fd02518517c338e92e6eabf00d10805cd71 /audio/slimserver-dynamictransition/Makefile
parent- Fix install on 4-STABLE. (diff)
This plugin looks at the songs before and after the current song
in the playlist and determines whether an album is playing or if random tracks are playing. After that determination, it sets the player's transition behavior (crossfade, fade, etc) appropriately. The transition behavior for the album/random/default cases can be changed by modifying the values of the four global variables at the top of Transitions.pm. There is also a user configurable section for excluding specific genres from being processed for album/random detection. In these cases, the 'default' transition preference will be used. WWW: http://www.sutula.us/james/slimserver/
Diffstat (limited to 'audio/slimserver-dynamictransition/Makefile')
-rw-r--r--audio/slimserver-dynamictransition/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/audio/slimserver-dynamictransition/Makefile b/audio/slimserver-dynamictransition/Makefile
new file mode 100644
index 000000000000..f1656295327e
--- /dev/null
+++ b/audio/slimserver-dynamictransition/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: slimserver-dynamictransition
+# Date created: 07 October 2006
+# Whom: Tim Bishop <tdb@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dynamictransition
+PORTVERSION= 1.4
+CATEGORIES= audio
+# Distfile mirrored due to being unversioned on author's site
+MASTER_SITES= ftp://ftp.i-scream.org/pub/slimserver/${PORTNAME}/ \
+ http://ftp.i-scream.org/pub/slimserver/${PORTNAME}/
+PKGNAMEPREFIX= slimserver-
+DISTNAME= Transitions-${PORTVERSION}
+EXTRACT_SUFX= .pm
+DIST_SUBDIR= slimserver
+
+MAINTAINER= tdb@FreeBSD.org
+COMMENT= SlimServer plugin for determining transition behaviour between tracks
+
+RUN_DEPENDS= softsqueeze:${PORTSDIR}/audio/slimserver
+
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS=
+EXTRACT_AFTER_ARGS= ${WRKSRC}
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+SLIMDIR?= slimserver
+PLIST_SUB+= SLIMDIR=${SLIMDIR}
+
+do-install:
+ ${MKDIR} ${PREFIX}/${SLIMDIR}/Plugins
+ ${INSTALL_DATA} ${WRKSRC}/Transitions-${PORTVERSION}.pm ${PREFIX}/${SLIMDIR}/Plugins/Transitions.pm
+
+.include <bsd.port.mk>