summaryrefslogtreecommitdiff
path: root/audio/rat/Makefile
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2000-09-18 16:06:05 +0000
committerAde Lovett <ade@FreeBSD.org>2000-09-18 16:06:05 +0000
commita87c59f3524ca031a40d21ba82e00b26383e6b6f (patch)
tree7d9fd80d7aa2313b384638ef50b34a852b94a8a1 /audio/rat/Makefile
parentUpdate to latest set of patches (diff)
The port was suffering bit rot deriving from differences between the
previous pcm driver and newpcm. This replacement port adds newpcm mixer support and brings port up to date with the current rat release (4.2.9). PR: 21333 Submitted by: maintainer
Diffstat (limited to 'audio/rat/Makefile')
-rw-r--r--audio/rat/Makefile18
1 files changed, 11 insertions, 7 deletions
diff --git a/audio/rat/Makefile b/audio/rat/Makefile
index 701628c69911..c03e840c70b1 100644
--- a/audio/rat/Makefile
+++ b/audio/rat/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= rat
-PORTVERSION= 4.0.4
+PORTVERSION= 4.2.9
CATEGORIES= mbone audio
-MASTER_SITES= http://www-mice.cs.ucl.ac.uk/multimedia/software/rat/4.0.4/ \
+MASTER_SITES= http://www-mice.cs.ucl.ac.uk/multimedia/software/rat/4.2.9/ \
${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= cpiazza
@@ -16,17 +16,22 @@ MAINTAINER= O.Hodson@cs.ucl.ac.uk
LIB_DEPENDS= tk82.1:${PORTSDIR}/x11-toolkits/tk82
+USE_AUTOCONF= yes
USE_GMAKE= yes
MAN1= rat.1
MANCOMPRESSED= no
+PATCH_DEBUG= yes
+
RAT_BUILD_DIRS= common rat
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/rat/rat-4.0.4 ${PREFIX}/bin/rat
+ ${INSTALL_PROGRAM} ${WRKSRC}/rat/rat ${PREFIX}/bin/rat
+ ${INSTALL_PROGRAM} ${WRKSRC}/rat/rat-ui ${PREFIX}/bin/rat-ui
+ ${INSTALL_PROGRAM} ${WRKSRC}/rat/rat-media ${PREFIX}/bin/rat-media
${INSTALL_MAN} ${WRKSRC}/rat/man/man1/rat.1 ${PREFIX}/man/man1
${MKDIR} ${LOCALBASE}/etc/sdr/plugins
- ${INSTALL_DATA} ${WRKSRC}/rat/sdr2.plugin.S02.audio.rtp.*.rat-4.0.4 ${LOCALBASE}/etc/sdr/plugins
+ ${INSTALL_DATA} ${WRKSRC}/rat/sdr2.plugin.S02.audio.rtp.*.rat ${LOCALBASE}/etc/sdr/plugins
do-build:
for d in ${RAT_BUILD_DIRS}; do \
@@ -34,8 +39,7 @@ do-build:
done
do-configure:
- for d in ${RAT_BUILD_DIRS}; do \
- cd ${WRKSRC}/$$d && ./configure; \
- done
+ cd ${WRKSRC}/common && ./configure
+ cd ${WRKSRC}/rat && autoconf && ./configure --with-tcl=${LOCALBASE} --with-tk=${LOCALBASE}
.include "bsd.port.mk"