summaryrefslogtreecommitdiff
path: root/audio/ogg2mp3
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2009-09-17 21:05:17 +0000
committerWesley Shields <wxs@FreeBSD.org>2009-09-17 21:05:17 +0000
commit1ae6e05c32eccc54dba192963337263489b3e9d6 (patch)
treed64939a1bef440a8a14b5a9c31c8fdfe56c22c99 /audio/ogg2mp3
parentFix type in last commit. (diff)
- Update to 0.6.1
- Update MASTER_SITES - Respect LOCALBASE PR: ports/138710 Submitted by: Tobias Rehbein <tobias.rehbein@web.de> (maintainer) Feature safe: yes
Diffstat (limited to 'audio/ogg2mp3')
-rw-r--r--audio/ogg2mp3/Makefile8
-rw-r--r--audio/ogg2mp3/distinfo6
-rw-r--r--audio/ogg2mp3/files/patch-ogg2mp341
-rw-r--r--audio/ogg2mp3/pkg-descr2
4 files changed, 18 insertions, 39 deletions
diff --git a/audio/ogg2mp3/Makefile b/audio/ogg2mp3/Makefile
index 04439d58ed00..3ab8ef5fe5d1 100644
--- a/audio/ogg2mp3/Makefile
+++ b/audio/ogg2mp3/Makefile
@@ -5,10 +5,9 @@
# $FreeBSD$
PORTNAME= ogg2mp3
-PORTVERSION= 0.5
-PORTREVISION= 3
+PORTVERSION= 0.6.1
CATEGORIES= audio
-MASTER_SITES= http://www.atarininja.org/distfiles/
+MASTER_SITES= http://jamesa.com/projects/ogg2mp3/releases/
MAINTAINER= tobias.rehbein@web.de
COMMENT= Perl script that converts Ogg Vorbis files to MP3 format
@@ -24,8 +23,7 @@ USE_PERL5= yes
PLIST_FILES= bin/ogg2mp3
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/bin|/usr/local/bin|g' \
- ${WRKSRC}/ogg2mp3
+ @${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|" ${WRKSRC}/ogg2mp3
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/ogg2mp3 ${PREFIX}/bin
diff --git a/audio/ogg2mp3/distinfo b/audio/ogg2mp3/distinfo
index c85355f61f38..b9830772b945 100644
--- a/audio/ogg2mp3/distinfo
+++ b/audio/ogg2mp3/distinfo
@@ -1,3 +1,3 @@
-MD5 (ogg2mp3-0.5.tar.bz2) = 283e3d255c344d41b340391a19cd2e65
-SHA256 (ogg2mp3-0.5.tar.bz2) = 46137c4a57d0abb9b976c8fe6f92aacc1daae02c6772a93fd0b8c66fe0968a4d
-SIZE (ogg2mp3-0.5.tar.bz2) = 12832
+MD5 (ogg2mp3-0.6.1.tar.bz2) = 6f254338ae7dae9b46e6638995d4e0a2
+SHA256 (ogg2mp3-0.6.1.tar.bz2) = 4f6ffeed81a36bf1b6715ce0213a57fa3e7e1f40f80f382e663060645400d84e
+SIZE (ogg2mp3-0.6.1.tar.bz2) = 12424
diff --git a/audio/ogg2mp3/files/patch-ogg2mp3 b/audio/ogg2mp3/files/patch-ogg2mp3
index 0e5bea7eb6fc..71eb2c96d65b 100644
--- a/audio/ogg2mp3/files/patch-ogg2mp3
+++ b/audio/ogg2mp3/files/patch-ogg2mp3
@@ -1,44 +1,23 @@
---- ./ogg2mp3.orig 2005-05-16 18:07:33.000000000 +0000
-+++ ./ogg2mp3 2009-02-08 12:29:27.000000000 +0000
+--- ./ogg2mp3.orig 2009-09-10 19:33:42.000000000 +0200
++++ ./ogg2mp3 2009-09-10 19:34:42.000000000 +0200
@@ -1,4 +1,4 @@
-#!/usr/bin/perl
-+#!/usr/local/bin/perl
++#!%%LOCALBASE%%/bin/perl
# ogg2mp3
- #
-@@ -51,10 +51,10 @@
- print " Thanks to all who took an interest. Have fun!\n";
+ # Maintained by: James Ausmus <james.ausmus.code@gmail.com>
+@@ -50,10 +50,10 @@
+ print " This code is released under the General Public License v2.\n";
print " ------------------------------------------------------------------- \n\n";
-my $MP3ENC = "/usr/bin/lame";
-#my $MP3INFO = "/usr/bin/mp3_check";
-my $OGGINFO = "/usr/bin/ogginfo";
-my $OGG123 = "/usr/bin/ogg123";
-+my $MP3ENC = "/usr/local/bin/lame";
-+#my $MP3INFO = "/usr/local/bin/mp3_check";
-+my $OGGINFO = "/usr/local/bin/ogginfo";
-+my $OGG123 = "/usr/local/bin/ogg123";
++my $MP3ENC = "%%LOCALBASE%%/bin/lame";
++#my $MP3INFO = "%%LOCALBASE%%/bin/mp3_check";
++my $OGGINFO = "%%LOCALBASE%%/bin/ogginfo";
++my $OGG123 = "%%LOCALBASE%%/bin/ogg123";
# check presence of executables
stat($MP3ENC) or die "Error: $MP3ENC not present!\n";
-@@ -68,7 +68,7 @@
-
- # build genre hash
- my %genres;
--open(GENRES, "$MP3ENC --genre-list|") or die "Couldn't get genre list with $MP3ENC --genre-list\n";
-+open(GENRES, "$MP3ENC --genre-list 2>&1 |") or die "Couldn't get genre list with $MP3ENC --genre-list\n";
- while(<GENRES>) {
- chomp;
- next if /^\s*$/;
-@@ -308,10 +308,8 @@
-
- $mp3outputfile_escaped = shell_quote($mp3outputfile);
- $oggfile_escaped = shell_quote($oggfile);
-- # this took me some time to figure
-- # note that byte order is swapped by lame via -x option
- # TODO: somebody please tell me how to supress the "Assuming bla bla" output without devnull
-- $result = system("$OGG123 $decquiet -d raw -f - $oggfile_escaped | $MP3ENC $encquiet -r -x -q $quality -b $bitrate -s $frequency -m $channels $infostring - $mp3outputfile_escaped");
-+ $result = system("$OGG123 $decquiet -d raw -f - $oggfile_escaped | $MP3ENC $encquiet -r -q $quality -b $bitrate -s $frequency -m $channels $infostring - $mp3outputfile_escaped");
-
- # TODO: find some widely used mp3 checker
- # disabled the checking due to lack of checker
diff --git a/audio/ogg2mp3/pkg-descr b/audio/ogg2mp3/pkg-descr
index 2e7df17864c4..b5a165a2d828 100644
--- a/audio/ogg2mp3/pkg-descr
+++ b/audio/ogg2mp3/pkg-descr
@@ -1 +1,3 @@
ogg2mp3 is a perl script that converts Ogg Vorbis files into MP3 format.
+
+WWW: http://gitorious.org/ogg2mp3/pages/Home