summaryrefslogtreecommitdiff
path: root/audio/normalize/Makefile
diff options
context:
space:
mode:
authorBrian Feldman <green@FreeBSD.org>2004-03-23 17:23:50 +0000
committerBrian Feldman <green@FreeBSD.org>2004-03-23 17:23:50 +0000
commit760315577e3aac7601aa5bbb065fbca1991f27f8 (patch)
tree14b877f0ca9f628f54844e3e6e46d0bc30b53995 /audio/normalize/Makefile
parentPR: ports/63652 (diff)
Add the ability to install the XMMS plugin (WITH_XMMS option).
Diffstat (limited to 'audio/normalize/Makefile')
-rw-r--r--audio/normalize/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/audio/normalize/Makefile b/audio/normalize/Makefile
index e99e1d34506e..d57cacde03be 100644
--- a/audio/normalize/Makefile
+++ b/audio/normalize/Makefile
@@ -7,7 +7,7 @@
PORTNAME= normalize
PORTVERSION= 0.7.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio
MASTER_SITES= http://www1.cs.columbia.edu/~cvaill/normalize/
@@ -16,17 +16,28 @@ COMMENT= A tool for adjusting the volume of wave/MP3 files to a standard level
LIB_DEPENDS= mad.2:${PORTSDIR}/audio/mad
+OPTIONS= XMMS "Build XMMS plugin" off
+.include <bsd.port.pre.mk>
+.if defined(WITH_XMMS)
+LIB_DEPENDS+= xmms.4:${PORTSDIR}/multimedia/xmms
+.endif
+
USE_BZIP2= yes
USE_GETOPT_LONG= yes
USE_GETTEXT= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+.if defined(WITH_XMMS)
+PLIST_SUB+= XMMS=""
+.else
CONFIGURE_ARGS= --disable-xmms
+PLIST_SUB+= XMMS="@comment "
+.endif
MAN1= normalize.1 normalize-mp3.1
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>