summaryrefslogtreecommitdiff
path: root/audio/normalize/Makefile
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2006-01-30 12:33:08 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2006-01-30 12:33:08 +0000
commit45095622a19ff393b7db3f468bab67aa3661d004 (patch)
tree21ce1a7335807ff0f0802b5be86804dda890776f /audio/normalize/Makefile
parentSHA256ify (diff)
Update to 0.7.7
Use audio/libmad instead meta port audio/mad Pass maintainer to submitter PR: 92514 Submitted by: Aleksander Fafula <alex@fafula.com> Approved by: maintainer
Diffstat (limited to 'audio/normalize/Makefile')
-rw-r--r--audio/normalize/Makefile34
1 files changed, 16 insertions, 18 deletions
diff --git a/audio/normalize/Makefile b/audio/normalize/Makefile
index ad6bfd16c106..9a2823a39e27 100644
--- a/audio/normalize/Makefile
+++ b/audio/normalize/Makefile
@@ -6,28 +6,31 @@
#
PORTNAME= normalize
-PORTVERSION= 0.7.6
-PORTREVISION= 3
+PORTVERSION= 0.7.7
CATEGORIES= audio
-MASTER_SITES= http://www1.cs.columbia.edu/~cvaill/normalize/
+MASTER_SITES= http://download.savannah.gnu.org/releases/normalize/
-MAINTAINER= itetcu@people.tecnik93.com
+MAINTAINER= alex@fafula.com
COMMENT= A tool for adjusting the volume of wave/MP3 files to a standard level
-LIB_DEPENDS= mad.2:${PORTSDIR}/audio/mad
+LIB_DEPENDS= mad.2:${PORTSDIR}/audio/libmad
+
+USE_BZIP2= yes
+USE_GETOPT_LONG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+
+MAN1= normalize.1 normalize-mp3.1
-USE_BZIP2= yes # XXX set before OPTIONS
OPTIONS= XMMS "Build XMMS plugin" off
+
.include <bsd.port.pre.mk>
-.if defined(WITH_XMMS)
-LIB_DEPENDS+= xmms.4:${PORTSDIR}/multimedia/xmms
-.endif
-USE_GETOPT_LONG= yes
-GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
.if defined(WITH_XMMS)
+LIB_DEPENDS+= xmms.4:${PORTSDIR}/multimedia/xmms
PLIST_SUB+= XMMS=""
PLIST_SUB+= X11BASE="${X11BASE}"
.else
@@ -43,9 +46,4 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-MAN1= normalize.1 normalize-mp3.1
-
-CPPFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
-
.include <bsd.port.post.mk>