summaryrefslogtreecommitdiff
path: root/audio/normalize/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-11-16 14:22:18 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-11-16 14:22:18 +0000
commit23e1072b98c728bfda8794aa059d5a82788ca6ee (patch)
tree849e9f64d28fb44bdf6a838badc8cbbf80fda60a /audio/normalize/Makefile
parent- Update to version 1.34 (diff)
- Update to version 0.7.6
PR: 59328 Submitted by: Ports Fury
Diffstat (limited to 'audio/normalize/Makefile')
-rw-r--r--audio/normalize/Makefile18
1 files changed, 13 insertions, 5 deletions
diff --git a/audio/normalize/Makefile b/audio/normalize/Makefile
index 0f9dcb6acd3b..181377b875f6 100644
--- a/audio/normalize/Makefile
+++ b/audio/normalize/Makefile
@@ -6,18 +6,26 @@
#
PORTNAME= normalize
-PORTVERSION= 0.7.5
-PORTREVISION= 2
+PORTVERSION= 0.7.6
CATEGORIES= audio
-MASTER_SITES= http://www.cs.columbia.edu/~cvaill/normalize/
+MASTER_SITES= http://www1.cs.columbia.edu/~cvaill/normalize/
MAINTAINER= ports@FreeBSD.org
COMMENT= A tool for adjusting the volume of wave/MP3 files to a standard level
-LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext
+LIB_DEPENDS= mad.1:${PORTSDIR}/audio/mad \
+ intl.5:${PORTSDIR}/devel/gettext
+
+USE_BZIP2= yes
+USE_GETOPT_LONG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS= --disable-xmms
MAN1= normalize.1 normalize-mp3.1
-GNU_CONFIGURE= yes
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
.include <bsd.port.mk>