summaryrefslogtreecommitdiff
path: root/audio/muse/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-12-22 11:56:46 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-12-22 11:56:46 +0000
commit79272bc6191b4e49cb95471e142338ef5b3f5d79 (patch)
treeb3a1a79a7f45e89e255165bb1ecdae70fd417075 /audio/muse/Makefile
parent- Update MASTER_SITES (remove dead mirror) (diff)
- Add WITHOUT_X11 knob
PR: 60459 Submitted by: Ports Fury
Diffstat (limited to 'audio/muse/Makefile')
-rw-r--r--audio/muse/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/audio/muse/Makefile b/audio/muse/Makefile
index 607f1ccf97f1..9988a792960e 100644
--- a/audio/muse/Makefile
+++ b/audio/muse/Makefile
@@ -23,17 +23,23 @@ LIB_DEPENDS= mp3lame.0:${PORTSDIR}/audio/lame \
USE_GETOPT_LONG= yes
USE_REINPLACE= yes
-USE_GNOME= gtk12
+USE_GNOME= gnometarget
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --disable-debug
MAN1= muse.1
-CPPFLAGS= -I${LOCALBASE}/include -DHAVE_DECL_GETOPT
-LDFLAGS= -L${LOCALBASE}/lib
+CPPFLAGS= -I${LOCALBASE}/include -DHAVE_DECL_GETOPT ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+
+.if defined(WITHOUT_X11)
+PKGNAMESUFFIX= -nox11
+CONFIGURE_ARGS+= --without-x --with-rubik
+.else
+USE_GNOME+= gtk12
+.endif
post-patch:
@${REINPLACE_CMD} -e 's|^CFLAGS=.*$$|CFLAGS="\$$CFLAGS"|g ; \