summaryrefslogtreecommitdiff
path: root/audio/mp3mover/Makefile
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2004-01-09 05:40:35 +0000
committerPete Fritchman <petef@FreeBSD.org>2004-01-09 05:40:35 +0000
commit8c48fce3cc6ec0d487cb4fd1e2c839085a43bc7c (patch)
tree1ba6915d6e069b5e0014ea5cb81cdc200daf04ff /audio/mp3mover/Makefile
parentUpdate to 2.1.4. (diff)
- update to 2.1.1
- use ${DATADIR}/%%DATADIR%% - install documentation + respect NOPORTDOCS PR: 61099 Submitted by: Vincent Tantardini <vinc@FreeBSD-fr.org>
Diffstat (limited to 'audio/mp3mover/Makefile')
-rw-r--r--audio/mp3mover/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/audio/mp3mover/Makefile b/audio/mp3mover/Makefile
index acd41d8ec68e..f091489ff390 100644
--- a/audio/mp3mover/Makefile
+++ b/audio/mp3mover/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= mp3mover
-PORTVERSION= 1.432
+PORTVERSION= 2.1.1
CATEGORIES= audio perl5
MASTER_SITES= http://www.doc.ic.ac.uk/~jsm00/scripts/
@@ -17,14 +17,18 @@ COMMENT= Rename mp3s and manipulate them
RUN_DEPENDS= ${SITE_PERL}/MP3/Tag.pm:${PORTSDIR}/audio/p5-tagged
USE_PERL5= yes
-
-WRKSRC= ${WRKDIR}/${PORTNAME}
NO_BUILD= yes
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/mp3mover.pl ${PREFIX}/bin/mp3mover
- @${MKDIR} ${PREFIX}/share/${PORTNAME}
- ${CP} ${WRKSRC}/sample-.mp3moverrc ${PREFIX}/share/${PORTNAME}
- ${CP} ${WRKSRC}/shellperfect-.mp3moverrc ${PREFIX}/share/${PORTNAME}
+ @${MKDIR} ${DATADIR}
+ ${CP} ${WRKSRC}/sample-.mp3moverrc ${DATADIR}
+ ${CP} ${WRKSRC}/shellperfect-.mp3moverrc ${DATADIR}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/readme ${DOCSDIR}
+.endif
.include <bsd.port.mk>