summaryrefslogtreecommitdiff
path: root/audio/mp3check/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-04-17 17:35:04 +0000
committerWill Andrews <will@FreeBSD.org>2001-04-17 17:35:04 +0000
commitd51c6df95cf9c0530c3e7dcbbfd66dc0053c22d0 (patch)
tree6e054567c6d38cd41f931223dfc13944a0d5b707 /audio/mp3check/Makefile
parentAdd pflogsumm 20000916.01, a Postfix Log Entry Summarizer. (diff)
Add mp3check 1.1, a tool for checking and fixing mp3 archive
inconsistencies. PR: 26612 Submitted by: Mark Pulford <mark@kyne.com.au>
Diffstat (limited to '')
-rw-r--r--audio/mp3check/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/audio/mp3check/Makefile b/audio/mp3check/Makefile
new file mode 100644
index 000000000000..1d2c179bb7e9
--- /dev/null
+++ b/audio/mp3check/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: mp3check
+# Date created: Apr 16, 2001
+# Whom: Mark Pulford <mark@kyne.com.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mp3check
+PORTVERSION= 1.1
+CATEGORIES= audio
+MASTER_SITES= http://www.icculus.org/mp3check/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX=
+
+MAINTAINER= mark@kyne.com.au
+
+RUN_DEPENDS= ${LOCALBASE}/bin/id3tool:${PORTSDIR}/audio/id3tool \
+ ${LOCALBASE}/bin/mp3_check:${PORTSDIR}/audio/mp3_check
+
+USE_PERL5= yes
+NO_WRKSUBDIR= yes
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS=
+EXTRACT_AFTER_ARGS= ${WRKSRC}
+NO_BUILD= yes
+
+pre-patch:
+ @${PERL} -pi -e "s|^#!.+|#!${PERL}|" ${WRKSRC}/mp3check
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/mp3check ${PREFIX}/bin
+
+.include <bsd.port.mk>