summaryrefslogtreecommitdiff
path: root/audio/libvorbis
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2001-03-23 22:21:39 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2001-03-23 22:21:39 +0000
commitc90c2320b14e365cadeb61355f718a854739c680 (patch)
tree0949769971ceed04cfca31a0fdd70613930914eb /audio/libvorbis
parentBump PORTREVISION due to patch-processesend.pl (diff)
Change maintainer for libao, libogg, libvorbis, and vorbis. Improve
use of autoconf and automake. Support NOPORTDOCS. Respect CFLAGS. Fix libvorbis encoder on Alpha. Install documentation in proper places. Approved by: Theo van Klaveren <t.vanklaveren@student.utwente.nl> (outgoing maintainer), Christian Weisgerber <naddy@mips.inka.de> (new maintainer)
Diffstat (limited to 'audio/libvorbis')
-rw-r--r--audio/libvorbis/Makefile8
-rw-r--r--audio/libvorbis/files/patch-ac11
-rw-r--r--audio/libvorbis/files/patch-configure56
-rw-r--r--audio/libvorbis/files/patch-doc_Makefile.in12
-rw-r--r--audio/libvorbis/files/patch-doc_vorbisenc_Makefile.in12
-rw-r--r--audio/libvorbis/files/patch-doc_vorbisfile_Makefile.in12
-rw-r--r--audio/libvorbis/files/patch-lib_psy.c12
-rw-r--r--audio/libvorbis/pkg-descr3
-rw-r--r--audio/libvorbis/pkg-plist121
9 files changed, 169 insertions, 78 deletions
diff --git a/audio/libvorbis/Makefile b/audio/libvorbis/Makefile
index c8d2280eb63c..2227fd0e881c 100644
--- a/audio/libvorbis/Makefile
+++ b/audio/libvorbis/Makefile
@@ -7,20 +7,20 @@
PORTNAME= libvorbis
PORTVERSION= 1.0b4
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= audio
MASTER_SITES= http://www.vorbis.com/files/beta4/unix/ \
http://home.student.utwente.nl/t.vanklaveren/distfiles/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/b/beta/}
-MAINTAINER= t.vanklaveren@student.utwente.nl
+MAINTAINER= Christian Weisgerber <naddy@mips.inka.de>
LIB_DEPENDS= ogg.1:${PORTSDIR}/audio/libogg
-USE_GMAKE= yes
USE_LIBTOOL= yes
CONFIGURE_ARGS= --with-ogg-prefix=${LOCALBASE}
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
-AUTOCONF_ARGS= ; ${PERL} -pi -e 's|-lpthread|-pthread|g' ${WRKSRC}/configure
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
.include <bsd.port.mk>
diff --git a/audio/libvorbis/files/patch-ac b/audio/libvorbis/files/patch-ac
deleted file mode 100644
index b19fc64a8391..000000000000
--- a/audio/libvorbis/files/patch-ac
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig Mon Feb 26 22:34:27 2001
-+++ configure Fri Mar 2 12:44:18 2001
-@@ -1710,7 +1710,7 @@
- PROFILE="-DDARWIN -fno-common -force_cpusubtype_ALL -Wall -g -pg -O4 -ffast-math -fsigned-char";;
- *)
- DEBUG="-g -Wall -D__NO_MATH_INLINES -fsigned-char"
-- CFLAGS="-O20 -D__NO_MATH_INLINES -fsigned-char"
-+ CFLAGS="-D__NO_MATH_INLINES -fsigned-char $CFLAGS"
- PROFILE="-O20 -g -pg -D__NO_MATH_INLINES -fsigned-char" ;;
- esac
- fi
diff --git a/audio/libvorbis/files/patch-configure b/audio/libvorbis/files/patch-configure
new file mode 100644
index 000000000000..bc1c134bfd43
--- /dev/null
+++ b/audio/libvorbis/files/patch-configure
@@ -0,0 +1,56 @@
+$FreeBSD$
+--- configure.orig Mon Feb 26 14:34:27 2001
++++ configure Wed Mar 21 15:45:36 2001
+@@ -1617,9 +1617,9 @@
+ CFLAGS="-xO4 -fast -w -fsimple -native -xcg92"
+ PROFILE="-v -xpg -g -xO4 -fast -native -fsimple -xcg92 -Dsuncc" ;;
+ *)
+- DEBUG="-g"
+- CFLAGS="-O"
+- PROFILE="-g -p" ;;
++ DEBUG="$CFLAGS -g"
++ CFLAGS="$CFLAGS"
++ PROFILE="$CFLAGS -g -p" ;;
+ esac
+ else
+
+@@ -1709,9 +1709,9 @@
+ CFLAGS="-DDARWIN -fno-common -force_cpusubtype_ALL -Wall -g -O4 -ffast-math -fsigned-char"
+ PROFILE="-DDARWIN -fno-common -force_cpusubtype_ALL -Wall -g -pg -O4 -ffast-math -fsigned-char";;
+ *)
+- DEBUG="-g -Wall -D__NO_MATH_INLINES -fsigned-char"
+- CFLAGS="-O20 -D__NO_MATH_INLINES -fsigned-char"
+- PROFILE="-O20 -g -pg -D__NO_MATH_INLINES -fsigned-char" ;;
++ DEBUG="$CFLAGS -g -Wall -D__NO_MATH_INLINES -fsigned-char"
++ CFLAGS="$CFLAGS -fsigned-char"
++ PROFILE="$CFLAGS -g -pg -D__NO_MATH_INLINES -fsigned-char" ;;
+ esac
+ fi
+
+@@ -1795,14 +1795,14 @@
+ LIBS=""
+ fi
+
+-echo $ac_n "checking for pthread_create in -lpthread""... $ac_c" 1>&6
+-echo "configure:1800: checking for pthread_create in -lpthread" >&5
++echo $ac_n "checking for pthread_create in -pthread""... $ac_c" 1>&6
++echo "configure:1800: checking for pthread_create in -pthread" >&5
+ ac_lib_var=`echo pthread'_'pthread_create | sed 'y%./+-%__p_%'`
+ if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ac_save_LIBS="$LIBS"
+-LIBS="-lpthread $LIBS"
++LIBS="-pthread $LIBS"
+ cat > conftest.$ac_ext <<EOF
+ #line 1808 "configure"
+ #include "confdefs.h"
+@@ -1830,7 +1830,7 @@
+ fi
+ if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
+ echo "$ac_t""yes" 1>&6
+- pthread_lib="-lpthread"
++ pthread_lib="-pthread"
+ else
+ echo "$ac_t""no" 1>&6
+ :
diff --git a/audio/libvorbis/files/patch-doc_Makefile.in b/audio/libvorbis/files/patch-doc_Makefile.in
new file mode 100644
index 000000000000..ad7d72081ed2
--- /dev/null
+++ b/audio/libvorbis/files/patch-doc_Makefile.in
@@ -0,0 +1,12 @@
+$FreeBSD$
+--- doc/Makefile.in.orig Wed Mar 21 15:53:20 2001
++++ doc/Makefile.in Wed Mar 21 15:53:49 2001
+@@ -89,7 +89,7 @@ AUTOMAKE_OPTIONS = foreign
+
+ SUBDIRS = vorbisfile vorbisenc
+
+-docdir = $(datadir)/doc/$(PACKAGE)-$(VERSION)
++docdir = $(datadir)/doc/$(PACKAGE)
+
+ doc_DATA = v-comment.html vorbisword2.png white-ogg.png programming.html vorbis.html wait.png white-xifish.png vorbis-clip.txt vorbis-errors.txt
+
diff --git a/audio/libvorbis/files/patch-doc_vorbisenc_Makefile.in b/audio/libvorbis/files/patch-doc_vorbisenc_Makefile.in
new file mode 100644
index 000000000000..f2c1ac93db01
--- /dev/null
+++ b/audio/libvorbis/files/patch-doc_vorbisenc_Makefile.in
@@ -0,0 +1,12 @@
+$FreeBSD$
+--- doc/vorbisenc/Makefile.in.orig Wed Mar 21 15:54:02 2001
++++ doc/vorbisenc/Makefile.in Wed Mar 21 15:54:16 2001
+@@ -87,7 +87,7 @@ pthread_lib = @pthread_lib@
+
+ AUTOMAKE_OPTIONS = foreign
+
+-docdir = $(datadir)/doc/$(PACKAGE)-$(VERSION)/vorbisenc
++docdir = $(datadir)/doc/$(PACKAGE)/vorbisenc
+
+ doc_DATA = index.html overview.html reference.html style.css vorbis_encode_ctl.html vorbis_encode_init.html vorbis_info.html
+
diff --git a/audio/libvorbis/files/patch-doc_vorbisfile_Makefile.in b/audio/libvorbis/files/patch-doc_vorbisfile_Makefile.in
new file mode 100644
index 000000000000..9e225fc71b4e
--- /dev/null
+++ b/audio/libvorbis/files/patch-doc_vorbisfile_Makefile.in
@@ -0,0 +1,12 @@
+$FreeBSD$
+--- doc/vorbisfile/Makefile.in.orig Wed Mar 21 15:54:31 2001
++++ doc/vorbisfile/Makefile.in Wed Mar 21 15:54:47 2001
+@@ -87,7 +87,7 @@ pthread_lib = @pthread_lib@
+
+ AUTOMAKE_OPTIONS = foreign
+
+-docdir = $(datadir)/doc/$(PACKAGE)-$(VERSION)/vorbisfile
++docdir = $(datadir)/doc/$(PACKAGE)/vorbisfile
+
+ doc_DATA = OggVorbis_File.html chaining_example_c.html chainingexample.html datastructures.html decoding.html example.html exampleindex.html fileinfo.html index.html initialization.html ov_bitrate.html ov_bitrate_instant.html ov_callbacks.html ov_clear.html ov_comment.html ov_info.html ov_open.html ov_open_callbacks.html ov_pcm_seek.html ov_pcm_tell.html ov_pcm_total.html ov_raw_seek.html ov_raw_tell.html ov_raw_total.html ov_read.html ov_seekable.html ov_serialnumber.html ov_streams.html ov_time_seek.html ov_time_tell.html ov_time_total.html overview.html reference.html seekexample.html seeking.html seeking_test_c.html seekingexample.html style.css vorbis_comment.html vorbis_info.html vorbisfile_example_c.html
+
diff --git a/audio/libvorbis/files/patch-lib_psy.c b/audio/libvorbis/files/patch-lib_psy.c
new file mode 100644
index 000000000000..c736d2bc7b4d
--- /dev/null
+++ b/audio/libvorbis/files/patch-lib_psy.c
@@ -0,0 +1,12 @@
+$FreeBSD$
+--- lib/psy.c.orig Mon Feb 26 05:37:59 2001
++++ lib/psy.c Wed Mar 21 15:50:10 2001
+@@ -191,7 +191,7 @@
+ p->total_octave_lines=maxoc-p->firstoc+1;
+
+ p->ath=_ogg_malloc(n*sizeof(float));
+- p->octave=_ogg_malloc(n*sizeof(int));
++ p->octave=_ogg_malloc(n*sizeof(long));
+ p->bark=_ogg_malloc(n*sizeof(float));
+ p->vi=vi;
+ p->n=n;
diff --git a/audio/libvorbis/pkg-descr b/audio/libvorbis/pkg-descr
index 262b3656ac22..973053f637bf 100644
--- a/audio/libvorbis/pkg-descr
+++ b/audio/libvorbis/pkg-descr
@@ -12,6 +12,3 @@ vorbisfile, an LGPLed convenience library built on Vorbis designed to simplify
common uses.
WWW: http://www.vorbis.com
-
-- Theo van Klaveren
-t.vanklaveren@student.utwente.nl
diff --git a/audio/libvorbis/pkg-plist b/audio/libvorbis/pkg-plist
index 6fb88f4e7559..c97b7db6375e 100644
--- a/audio/libvorbis/pkg-plist
+++ b/audio/libvorbis/pkg-plist
@@ -1,3 +1,4 @@
+@comment $FreeBSD$
include/vorbis/codec.h
include/vorbis/vorbisenc.h
include/vorbis/vorbisfile.h
@@ -11,64 +12,64 @@ lib/libvorbisfile.a
lib/libvorbisfile.so
lib/libvorbisfile.so.0
share/aclocal/vorbis.m4
-share/doc/libvorbis-1.0beta4/programming.html
-share/doc/libvorbis-1.0beta4/v-comment.html
-share/doc/libvorbis-1.0beta4/vorbis-clip.txt
-share/doc/libvorbis-1.0beta4/vorbis-errors.txt
-share/doc/libvorbis-1.0beta4/vorbis.html
-share/doc/libvorbis-1.0beta4/vorbisenc/index.html
-share/doc/libvorbis-1.0beta4/vorbisenc/overview.html
-share/doc/libvorbis-1.0beta4/vorbisenc/reference.html
-share/doc/libvorbis-1.0beta4/vorbisenc/style.css
-share/doc/libvorbis-1.0beta4/vorbisenc/vorbis_encode_ctl.html
-share/doc/libvorbis-1.0beta4/vorbisenc/vorbis_encode_init.html
-share/doc/libvorbis-1.0beta4/vorbisenc/vorbis_info.html
-share/doc/libvorbis-1.0beta4/vorbisfile/OggVorbis_File.html
-share/doc/libvorbis-1.0beta4/vorbisfile/chaining_example_c.html
-share/doc/libvorbis-1.0beta4/vorbisfile/chainingexample.html
-share/doc/libvorbis-1.0beta4/vorbisfile/datastructures.html
-share/doc/libvorbis-1.0beta4/vorbisfile/decoding.html
-share/doc/libvorbis-1.0beta4/vorbisfile/example.html
-share/doc/libvorbis-1.0beta4/vorbisfile/exampleindex.html
-share/doc/libvorbis-1.0beta4/vorbisfile/fileinfo.html
-share/doc/libvorbis-1.0beta4/vorbisfile/index.html
-share/doc/libvorbis-1.0beta4/vorbisfile/initialization.html
-share/doc/libvorbis-1.0beta4/vorbisfile/ov_bitrate.html
-share/doc/libvorbis-1.0beta4/vorbisfile/ov_bitrate_instant.html
-share/doc/libvorbis-1.0beta4/vorbisfile/ov_callbacks.html
-share/doc/libvorbis-1.0beta4/vorbisfile/ov_clear.html
-share/doc/libvorbis-1.0beta4/vorbisfile/ov_comment.html
-share/doc/libvorbis-1.0beta4/vorbisfile/ov_info.html
-share/doc/libvorbis-1.0beta4/vorbisfile/ov_open.html
-share/doc/libvorbis-1.0beta4/vorbisfile/ov_open_callbacks.html
-share/doc/libvorbis-1.0beta4/vorbisfile/ov_pcm_seek.html
-share/doc/libvorbis-1.0beta4/vorbisfile/ov_pcm_tell.html
-share/doc/libvorbis-1.0beta4/vorbisfile/ov_pcm_total.html
-share/doc/libvorbis-1.0beta4/vorbisfile/ov_raw_seek.html
-share/doc/libvorbis-1.0beta4/vorbisfile/ov_raw_tell.html
-share/doc/libvorbis-1.0beta4/vorbisfile/ov_raw_total.html
-share/doc/libvorbis-1.0beta4/vorbisfile/ov_read.html
-share/doc/libvorbis-1.0beta4/vorbisfile/ov_seekable.html
-share/doc/libvorbis-1.0beta4/vorbisfile/ov_serialnumber.html
-share/doc/libvorbis-1.0beta4/vorbisfile/ov_streams.html
-share/doc/libvorbis-1.0beta4/vorbisfile/ov_time_seek.html
-share/doc/libvorbis-1.0beta4/vorbisfile/ov_time_tell.html
-share/doc/libvorbis-1.0beta4/vorbisfile/ov_time_total.html
-share/doc/libvorbis-1.0beta4/vorbisfile/overview.html
-share/doc/libvorbis-1.0beta4/vorbisfile/reference.html
-share/doc/libvorbis-1.0beta4/vorbisfile/seekexample.html
-share/doc/libvorbis-1.0beta4/vorbisfile/seeking.html
-share/doc/libvorbis-1.0beta4/vorbisfile/seeking_test_c.html
-share/doc/libvorbis-1.0beta4/vorbisfile/style.css
-share/doc/libvorbis-1.0beta4/vorbisfile/seekingexample.html
-share/doc/libvorbis-1.0beta4/vorbisfile/vorbis_comment.html
-share/doc/libvorbis-1.0beta4/vorbisfile/vorbis_info.html
-share/doc/libvorbis-1.0beta4/vorbisfile/vorbisfile_example_c.html
-share/doc/libvorbis-1.0beta4/vorbisword2.png
-share/doc/libvorbis-1.0beta4/wait.png
-share/doc/libvorbis-1.0beta4/white-ogg.png
-share/doc/libvorbis-1.0beta4/white-xifish.png
+share/doc/libvorbis/programming.html
+share/doc/libvorbis/v-comment.html
+share/doc/libvorbis/vorbis-clip.txt
+share/doc/libvorbis/vorbis-errors.txt
+share/doc/libvorbis/vorbis.html
+share/doc/libvorbis/vorbisenc/index.html
+share/doc/libvorbis/vorbisenc/overview.html
+share/doc/libvorbis/vorbisenc/reference.html
+share/doc/libvorbis/vorbisenc/style.css
+share/doc/libvorbis/vorbisenc/vorbis_encode_ctl.html
+share/doc/libvorbis/vorbisenc/vorbis_encode_init.html
+share/doc/libvorbis/vorbisenc/vorbis_info.html
+share/doc/libvorbis/vorbisfile/OggVorbis_File.html
+share/doc/libvorbis/vorbisfile/chaining_example_c.html
+share/doc/libvorbis/vorbisfile/chainingexample.html
+share/doc/libvorbis/vorbisfile/datastructures.html
+share/doc/libvorbis/vorbisfile/decoding.html
+share/doc/libvorbis/vorbisfile/example.html
+share/doc/libvorbis/vorbisfile/exampleindex.html
+share/doc/libvorbis/vorbisfile/fileinfo.html
+share/doc/libvorbis/vorbisfile/index.html
+share/doc/libvorbis/vorbisfile/initialization.html
+share/doc/libvorbis/vorbisfile/ov_bitrate.html
+share/doc/libvorbis/vorbisfile/ov_bitrate_instant.html
+share/doc/libvorbis/vorbisfile/ov_callbacks.html
+share/doc/libvorbis/vorbisfile/ov_clear.html
+share/doc/libvorbis/vorbisfile/ov_comment.html
+share/doc/libvorbis/vorbisfile/ov_info.html
+share/doc/libvorbis/vorbisfile/ov_open.html
+share/doc/libvorbis/vorbisfile/ov_open_callbacks.html
+share/doc/libvorbis/vorbisfile/ov_pcm_seek.html
+share/doc/libvorbis/vorbisfile/ov_pcm_tell.html
+share/doc/libvorbis/vorbisfile/ov_pcm_total.html
+share/doc/libvorbis/vorbisfile/ov_raw_seek.html
+share/doc/libvorbis/vorbisfile/ov_raw_tell.html
+share/doc/libvorbis/vorbisfile/ov_raw_total.html
+share/doc/libvorbis/vorbisfile/ov_read.html
+share/doc/libvorbis/vorbisfile/ov_seekable.html
+share/doc/libvorbis/vorbisfile/ov_serialnumber.html
+share/doc/libvorbis/vorbisfile/ov_streams.html
+share/doc/libvorbis/vorbisfile/ov_time_seek.html
+share/doc/libvorbis/vorbisfile/ov_time_tell.html
+share/doc/libvorbis/vorbisfile/ov_time_total.html
+share/doc/libvorbis/vorbisfile/overview.html
+share/doc/libvorbis/vorbisfile/reference.html
+share/doc/libvorbis/vorbisfile/seekexample.html
+share/doc/libvorbis/vorbisfile/seeking.html
+share/doc/libvorbis/vorbisfile/seeking_test_c.html
+share/doc/libvorbis/vorbisfile/style.css
+share/doc/libvorbis/vorbisfile/seekingexample.html
+share/doc/libvorbis/vorbisfile/vorbis_comment.html
+share/doc/libvorbis/vorbisfile/vorbis_info.html
+share/doc/libvorbis/vorbisfile/vorbisfile_example_c.html
+share/doc/libvorbis/vorbisword2.png
+share/doc/libvorbis/wait.png
+share/doc/libvorbis/white-ogg.png
+share/doc/libvorbis/white-xifish.png
@dirrm include/vorbis
-@dirrm share/doc/libvorbis-1.0beta4/vorbisenc
-@dirrm share/doc/libvorbis-1.0beta4/vorbisfile
-@dirrm share/doc/libvorbis-1.0beta4
+@dirrm share/doc/libvorbis/vorbisenc
+@dirrm share/doc/libvorbis/vorbisfile
+@dirrm share/doc/libvorbis