summaryrefslogtreecommitdiff
path: root/audio/libamrwb/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-07-14 21:39:54 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-07-14 21:39:54 +0000
commit08b574207595f41bec773a876c9b3586b11878ae (patch)
treee242ef80f9b5948d4d177e61cff39aafb95af347 /audio/libamrwb/Makefile
parentUpdate to SRC680_m220. (diff)
- Fix Build
- Makefile cleanup PR: 113641 Submitted by: pointyhat via kris/pav Tatsuki Makino <tatsuki_makino@hotmail.com> (Maintainer) Thanks to: Fredrik Lindberg, linimon Reviewed by: sat
Diffstat (limited to 'audio/libamrwb/Makefile')
-rw-r--r--audio/libamrwb/Makefile38
1 files changed, 28 insertions, 10 deletions
diff --git a/audio/libamrwb/Makefile b/audio/libamrwb/Makefile
index ab40db506f20..f8d22e24c87d 100644
--- a/audio/libamrwb/Makefile
+++ b/audio/libamrwb/Makefile
@@ -7,16 +7,20 @@
PORTNAME= libamrwb
PORTVERSION= 7.0.0.1
+PORTREVISION= 1
CATEGORIES= audio
-MASTER_SITES= http://ftp.penguin.cz/pub/users/utx/amr/
+MASTER_SITES= http://ftp.penguin.cz/pub/users/utx/amr/ \
+ http://www.3gpp.org/ftp/Specs/archive/26_series/26.204/:3GPP
DISTNAME= amrwb-${DISTVERSION}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${SRC3GPP}:3GPP
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= tatsuki_makino@hotmail.com
-COMMENT= Adaptive Multi-Rate - Wideband (AMR-WB) Speech Codec
+COMMENT= 3GPP Adaptive Multi-Rate - Wideband (AMR-WB) Speech Codec
-BUILD_DEPENDS= wget:${PORTSDIR}/ftp/wget \
- ${UNZIP_CMD}:${PORTSDIR}/archivers/unzip \
- bash:${PORTSDIR}/shells/bash
+BUILD_DEPENDS= ${UNZIP_CMD}:${PORTSDIR}/archivers/unzip
+
+SRC3GPP= 26204-700.zip
USE_BZIP2= yes
USE_GMAKE= yes
@@ -24,11 +28,25 @@ USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
CONFIGURE_ENV+= LANG=C
USE_LDCONFIG= yes
-RESTRICTED= See Important legal notice of http://www.penguin.cz/~utx/amr.en.html
+RESTRICTED= license prohibits redistribution
+RESTRICTED_FILES= ${SRC3GPP}
+PORTDOCS= AUTHORS COPYING ChangeLog NEWS README TODO readme.txt
+SUB_FILES= pkg-message
+
+post-extract:
+ @${CP} ${DISTDIR}/${SRC3GPP} ${WRKSRC}/
-post-patch:
- @${REINPLACE_CMD} -E \
- -e "s!(/bin/bash)!${LOCALBASE}\\1!" \
- ${WRKSRC}/prepare_sources.sh
+post-install:
+.ifndef(NOPORTDOCS)
+ @${ECHO} -n Install documents:
+ @${MKDIR} ${DOCSDIR}
+. for FILE in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+ @${ECHO} -n " ${FILE}"
+. endfor
+ @${ECHO} .
+ @${ECHO}
+.endif
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>