summaryrefslogtreecommitdiff
path: root/audio/icecast/Makefile
diff options
context:
space:
mode:
authorDonald Burr <dburr@FreeBSD.org>1999-10-05 04:59:12 +0000
committerDonald Burr <dburr@FreeBSD.org>1999-10-05 04:59:12 +0000
commitefc5be687408dea314e22136693ee4237b55cb5d (patch)
treea75c02226f2c1fb6d3200b6bfd8930e971b4aa5a /audio/icecast/Makefile
parentUpdate to 2.5 (diff)
Upgrade icecast to 1.3.0.
Approved by port maintainer.
Diffstat (limited to 'audio/icecast/Makefile')
-rw-r--r--audio/icecast/Makefile33
1 files changed, 28 insertions, 5 deletions
diff --git a/audio/icecast/Makefile b/audio/icecast/Makefile
index 8dc5c0e6782f..ac3cd551aacf 100644
--- a/audio/icecast/Makefile
+++ b/audio/icecast/Makefile
@@ -1,37 +1,60 @@
# New ports collection makefile for: icecast
-# Version required: 1.1.4
+# Version required: 1.3.0
# Date created: 28 Jan 1999
# Whom: Chip Marshall <chip@eboai.org>
#
# $FreeBSD$
#
-DISTNAME= icecast-1.1.4
+DISTNAME= icecast-1.3.0
CATEGORIES= audio net
-MASTER_SITES= http://icecast.linuxpower.org/releases/ \
+MASTER_SITES= http://www.icecast.org/releases/ \
ftp://ftp.eboai.org/pub/icecast/
MAINTAINER= chip@eboai.org
+WRKSRC= ${WRKDIR}/icecast-1.3
+
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-crypt --with-libwrap
+CONFIGURE_ARGS= --with-libwrap
+
+do-configure:
+ cd ${WRKSRC} && ${SH} ./configure ${CONFIGURE_ARGS}
+ cd ${WRKSRC}/liveice && ${SH} ./configure ${CONFIGURE_ARGS}
+
+do-build:
+ cd ${WRKSRC} && ${MAKE}
+ cd ${WRKSRC} && ${MAKE} mkpasswd
+ cd ${WRKSRC}/liveice && ${MAKE}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/icecast ${PREFIX}/sbin
+ ${INSTALL_PROGRAM} ${WRKSRC}/mkpasswd ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/shout/listen ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/shout/shout ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/shout/calibrate ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/shout/stresstest ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/liveice/liveice ${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/misc/iceplay ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/shout/iceplay ${PREFIX}/bin
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/icecast
${INSTALL_MAN} ${WRKSRC}/doc/* ${PREFIX}/share/doc/icecast
+ ${INSTALL_MAN} ${WRKSRC}/liveice/README.liveice ${PREFIX}/share/doc/icecast
+ ${INSTALL_MAN} ${WRKSRC}/liveice/README.xingmp3enc ${PREFIX}/share/doc/icecast
+ ${INSTALL_MAN} ${WRKSRC}/liveice/README_new_mixer.txt ${PREFIX}/share/doc/icecast
${MKDIR} ${PREFIX}/share/examples/icecast
+ ${INSTALL_MAN} ${WRKSRC}/icecast.conf ${PREFIX}/share/examples/icecast
${INSTALL_MAN} ${WRKSRC}/liveice/liveice.cfg ${PREFIX}/share/examples/icecast
${INSTALL_MAN} ${WRKSRC}/shout/shoutrc.example ${PREFIX}/share/examples/icecast
${INSTALL_MAN} ${WRKSRC}/shout/playlist.example ${PREFIX}/share/examples/icecast
${INSTALL_MAN} ${WRKSRC}/shout/radio.tcl.example ${PREFIX}/share/examples/icecast
${MKDIR} ${PREFIX}/share/examples/icecast/icedir
${INSTALL_MAN} ${WRKSRC}/icedir/* ${PREFIX}/share/examples/icecast/icedir
+ ${MKDIR} ${PREFIX}/share/examples/icecast/templates
+ ${INSTALL_MAN} ${WRKSRC}/templates/* ${PREFIX}/share/examples/icecast/templates
+ ${INSTALL_MAN} ${WRKSRC}/liveice/frontend.tcl ${PREFIX}/share/examples/icecast
+ ${INSTALL_MAN} ${WRKSRC}/liveice/liveiceconfigure.tk ${PREFIX}/share/examples/icecast
.endif
+ @${CAT} ${PKGDIR}/MESSAGE
.include <bsd.port.mk>