summaryrefslogtreecommitdiff
path: root/audio/icecast/Makefile
diff options
context:
space:
mode:
authorJeremy Lea <reg@FreeBSD.org>2000-01-28 11:05:19 +0000
committerJeremy Lea <reg@FreeBSD.org>2000-01-28 11:05:19 +0000
commit59b9d1157832ae4562be296f81dc245c35ca96cd (patch)
tree9393a4e9e7b8ddd655227fd63fc99d77cde5b3cd /audio/icecast/Makefile
parentCorrect usage of libc_r. (diff)
Make this port compile on -current. Fix CFLAGS and libc_r usage.
Reformat MESSAGE so it is more visible. No response from: maintainer
Diffstat (limited to 'audio/icecast/Makefile')
-rw-r--r--audio/icecast/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/audio/icecast/Makefile b/audio/icecast/Makefile
index ac3cd551aacf..b0485d7dc03e 100644
--- a/audio/icecast/Makefile
+++ b/audio/icecast/Makefile
@@ -18,14 +18,13 @@ WRKSRC= ${WRKDIR}/icecast-1.3
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libwrap
-do-configure:
- cd ${WRKSRC} && ${SH} ./configure ${CONFIGURE_ARGS}
- cd ${WRKSRC}/liveice && ${SH} ./configure ${CONFIGURE_ARGS}
-
-do-build:
- cd ${WRKSRC} && ${MAKE}
- cd ${WRKSRC} && ${MAKE} mkpasswd
- cd ${WRKSRC}/liveice && ${MAKE}
+ALL_TARGET= all mkpasswd
+
+post-configure:
+ @${MAKE} WRKSRC=${WRKSRC}/liveice do-configure
+
+post-build:
+ @${MAKE} WRKSRC=${WRKSRC}/liveice ALL_TARGET=all do-build
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/icecast ${PREFIX}/sbin