summaryrefslogtreecommitdiff
path: root/audio/icecast/Makefile
diff options
context:
space:
mode:
authorJustin M. Seger <jseger@FreeBSD.org>1999-04-07 17:58:43 +0000
committerJustin M. Seger <jseger@FreeBSD.org>1999-04-07 17:58:43 +0000
commit38cdef4a3d4b04497b34fad797cb2391252833c7 (patch)
tree728e167238d758cb63f767fdfce5ba96085912b5 /audio/icecast/Makefile
parentMASTER_SITE_DIR had a leading / which caused fetch to disallow fetching (diff)
Upgrade to icecast-1.1.3
PR: ports/10994 Submitted by: mharo@area51.fremont.ca.us
Diffstat (limited to 'audio/icecast/Makefile')
-rw-r--r--audio/icecast/Makefile19
1 files changed, 11 insertions, 8 deletions
diff --git a/audio/icecast/Makefile b/audio/icecast/Makefile
index e6b84034cd21..6d197e6630fa 100644
--- a/audio/icecast/Makefile
+++ b/audio/icecast/Makefile
@@ -3,10 +3,10 @@
# Date created: 28 Jan 1999
# Whom: Chip Marshall <chip@eboai.org>
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1999/04/02 04:23:49 steve Exp $
#
-DISTNAME= icecast-1.1.0
+DISTNAME= icecast-1.1.3
CATEGORIES= audio net
MASTER_SITES= http://icecast.linuxpower.org/releases/ \
ftp://ftp.eboai.org/pub/icecast/
@@ -14,19 +14,22 @@ MASTER_SITES= http://icecast.linuxpower.org/releases/ \
MAINTAINER= chip@eboai.org
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-crypt --with-libwrap
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/icecast ${PREFIX}/sbin
- ${INSTALL_PROGRAM} ${WRKSRC}/iceplay/listen ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/iceplay/shout ${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/iceplay/iceplay ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/liveice/liveice ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/shout/listen ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/shout/shout ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/misc/iceplay ${PREFIX}/bin
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/icecast
${INSTALL_MAN} ${WRKSRC}/doc/* ${PREFIX}/share/doc/icecast
${MKDIR} ${PREFIX}/share/examples/icecast
- ${INSTALL_MAN} ${WRKSRC}/iceplay/shoutrc.example ${PREFIX}/share/examples/icecast
- ${INSTALL_MAN} ${WRKSRC}/iceplay/playlist.example ${PREFIX}/share/examples/icecast
- ${INSTALL_MAN} ${WRKSRC}/iceplay/radio.tcl.example ${PREFIX}/share/examples/icecast
+ ${INSTALL_MAN} ${WRKSRC}/shout/shoutrc.example ${PREFIX}/share/examples/icecast
+ ${INSTALL_MAN} ${WRKSRC}/shout/playlist.example ${PREFIX}/share/examples/icecast
+ ${INSTALL_MAN} ${WRKSRC}/shout/radio.tcl.example ${PREFIX}/share/examples/icecast
+ ${INSTALL_MAN} ${WRKSRC}/liveice/liveice.cfg ${PREFIX}/share/examples/icecast
${MKDIR} ${PREFIX}/share/examples/icecast/icedir
${INSTALL_MAN} ${WRKSRC}/icedir/* ${PREFIX}/share/examples/icecast/icedir
.endif