summaryrefslogtreecommitdiff
path: root/audio/gdam/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-11-06 22:48:48 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-11-06 22:48:48 +0000
commit699802796e9c26d15ae587a5ed62ff6e9281328b (patch)
tree4fa37d87ca3a58d987dc32d05cca27e3940ae006 /audio/gdam/Makefile
parentupdate MASTER_SITES [1] (diff)
Add gdam, a DJ mixing application suitable for live performances. GDam offers:
* Client/server architecture * Mixing of multiple mp3 files * Dynamic filter insertion and removal * Multiple sound device support (speakers and monitor) * Loops, queues, sampler, beat matching, sequencer * Record your performance to a disk And it's blue! PR: 59025 Submitted by: Pav Lucistnik <pav@oook.cz> Requested by: Martin Vana <martin.vana@vslib.cz>
Diffstat (limited to 'audio/gdam/Makefile')
-rw-r--r--audio/gdam/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/audio/gdam/Makefile b/audio/gdam/Makefile
new file mode 100644
index 000000000000..81c93543e75e
--- /dev/null
+++ b/audio/gdam/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: gdam
+# Date created: 6th Nov 2003
+# Whom: Pav Lucistnik <pav@oook.cz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gdam
+PORTVERSION= 0.942
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= pav@oook.cz
+COMMENT= DJ mixing software suitable for live performances
+
+BUILD_DEPENDS= ${X11BASE}/include/xmms/plugin.h:${PORTSDIR}/multimedia/xmms
+RUN_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123
+
+MAN1= gdamcli.1 gdamladspapluginscanner.1 gdam123.1 gdam-launcher.1 gdam-server.1
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_GNOME= libglade
+USE_LIBTOOL= yes
+USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lglib -lgtk|-lglib12 -lgtk12|' ${WRKSRC}/skin/foreign/xmmsvis/Makefile.in
+
+.include <bsd.port.mk>