summaryrefslogtreecommitdiff
path: root/audio/funktrackergold
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-04-14 20:53:41 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-04-14 20:53:41 +0000
commit49005238535b257ce8c7938dd27544e62b2ab58f (patch)
tree675b6c78a419665c86063bf2e4bd6e60d9045342 /audio/funktrackergold
parentBased on the popular Quake3 modification, "True Combat", TC:E provides (diff)
Fix a crash on startup.
PR: ports/71591 Submitted by: Shawn K. Quinn <skquinn@xevious.kicks-ass.net>, Simon Barner <barner@in.tum.de> Approved by: adamw (mentor), maintainer timeout
Diffstat (limited to 'audio/funktrackergold')
-rw-r--r--audio/funktrackergold/Makefile1
-rw-r--r--audio/funktrackergold/files/patch-funkgold__misc.c26
2 files changed, 27 insertions, 0 deletions
diff --git a/audio/funktrackergold/Makefile b/audio/funktrackergold/Makefile
index b2a450e819a7..4c77ad258615 100644
--- a/audio/funktrackergold/Makefile
+++ b/audio/funktrackergold/Makefile
@@ -7,6 +7,7 @@
PORTNAME= funktrackergold
PORTVERSION= 1.5.2
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SUNSITE} \
http://jsno.leal.com.au/rel/unix_projects/
diff --git a/audio/funktrackergold/files/patch-funkgold__misc.c b/audio/funktrackergold/files/patch-funkgold__misc.c
new file mode 100644
index 000000000000..3557cd198a77
--- /dev/null
+++ b/audio/funktrackergold/files/patch-funkgold__misc.c
@@ -0,0 +1,26 @@
+--- funkgold_misc.c.orig Thu Apr 14 17:48:48 2005
++++ funkgold_misc.c Thu Apr 14 17:49:42 2005
+@@ -30,22 +30,7 @@
+
+ void get_environment(void)
+ {
+- char *os_type = getenv("OSTYPE");
+- register int x;
+- char *os_tt[] = {
+- "Linux",
+- "FreeBSD"
+- };
+-
+- for(x = 0;x < SO_TT_SIZE;x++)
+- if(strcmp(os_tt[x],os_type) == 0)
+- break;
+- switch(x)
+- {
+- case 0: funk_info.funk_cpu_type = FKCPU_LINUX; break;
+- case 1: funk_info.funk_cpu_type = FKCPU_FREEBSD; break;
+- default: funk_info.funk_cpu_type = FKCPU_UNKNOWN; break;
+- }
++ funk_info.funk_cpu_type = FKCPU_FREEBSD;
+ }
+
+ /***************************************************************************