summaryrefslogtreecommitdiff
path: root/audio/dap/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>1998-09-16 12:54:00 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>1998-09-16 12:54:00 +0000
commit1ec5a23dde11bd9476cf547367f7acda1d83a794 (patch)
tree5a17cd1a72fbe12346e98f2c98cfc2550eff9ec6 /audio/dap/Makefile
parentUpgrade to 1.02. (diff)
Digital Audio Processor.
PR: ports/7719 Submitted by: Yoshiaki Uchikawa <yoshiaki@kt.rim.or.jp>
Diffstat (limited to 'audio/dap/Makefile')
-rw-r--r--audio/dap/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/audio/dap/Makefile b/audio/dap/Makefile
new file mode 100644
index 000000000000..e1c63b3a41dc
--- /dev/null
+++ b/audio/dap/Makefile
@@ -0,0 +1,31 @@
+# ports collection makefile for: dap
+# Version required: 1.3b
+# Date created: 23 August 1998
+# Whom: yoshiaki Uchikawa
+#
+# $Id$
+#
+
+DISTNAME= DAPSource
+PKGNAME= dap-1.3b
+CATEGORIES= audio
+MASTER_SITES= http://www.cee.hw.ac.uk/~richardk/
+
+MAINTAINER= yoshiaki@kt.rim.or.jp
+
+LIB_DEPENDS= xforms\\.0\\.88:${PORTSDIR}/x11-toolkits/xforms
+
+WRKSRC= ${WRKDIR}/dap
+USE_X_PREFIX= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/main/DAP ${PREFIX}/bin/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/DAP/
+ ${INSTALL_MAN} ${WRKSRC}/COPYING ${WRKSRC}/README \
+ ${WRKSRC}/THANKS ${WRKSRC}/TODO ${PREFIX}/share/doc/DAP/
+.endif
+post-install:
+ strip ${PREFIX}/bin/DAP
+
+.include <bsd.port.mk>