summaryrefslogtreecommitdiff
path: root/audio/checkmate/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-09-26 13:53:01 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-09-26 13:53:01 +0000
commit519f4e67779863399411e061efabaef354e042bc (patch)
tree27969723a2136a2643421f17465cc839dd81361c /audio/checkmate/Makefile
parentUpdate to 3.2.7 [1] (diff)
Add mpck 0.10, a command-line utility for checking mp3 files for errors.
PR: ports/86553 Submitted by: Emanuel Haupt <ehaupt@critical.ch>
Diffstat (limited to 'audio/checkmate/Makefile')
-rw-r--r--audio/checkmate/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/audio/checkmate/Makefile b/audio/checkmate/Makefile
new file mode 100644
index 000000000000..a484be8b99a1
--- /dev/null
+++ b/audio/checkmate/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: mpck
+# Date created: 25 Sep 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mpck
+PORTVERSION= 0.10
+CATEGORIES= audio
+MASTER_SITES= http://mpck.linuxonly.nl/
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= A command-line utility for checking mp3 files for errors
+
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+MAN1= mpck.1
+PLIST_FILES= bin/mpck
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|<malloc.h>|<stdlib.h>|' \
+ ${WRKSRC}/src/checkframe.c \
+ ${WRKSRC}/src/bufio.c
+
+.include <bsd.port.mk>