summaryrefslogtreecommitdiff
path: root/astro
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-01-29 09:33:26 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-01-29 09:33:26 +0000
commitd5819cf5478f5c222d63b9fd7a583910a204ab12 (patch)
tree70921f07b2dd2adb1e2bd7b39922fb3af0c2bdf5 /astro
parentUse ${ECHO_CMD} instead of ${ECHO} where you mean the echo command; (diff)
Use ${ECHO_CMD} instead of ${ECHO} where you mean the echo command;
the ECHO macro is set to "echo" by default, but it is set to "true" if make(1) is invoked with the -s option while ECHO_CMD is always set to the echo command. Use command macros where appropriate.
Diffstat (limited to 'astro')
-rw-r--r--astro/xephem/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/astro/xephem/Makefile b/astro/xephem/Makefile
index b3bb722d592e..72bca5131eb5 100644
--- a/astro/xephem/Makefile
+++ b/astro/xephem/Makefile
@@ -31,14 +31,14 @@ post-patch:
pre-build:
@cd ${LIBASTROSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE}
@cd ${LIBIPSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE}
- @${ECHO} 'XEphem.ShareDir: ${PREFIX}/lib/X11/xephem' > ${WRKSRC}/XEphem.ad
+ @${ECHO_CMD} 'XEphem.ShareDir: ${PREFIX}/lib/X11/xephem' > ${WRKSRC}/XEphem.ad
post-install:
${INSTALL_DATA} ${WRKSRC}/XEphem.ad ${PREFIX}/lib/X11/app-defaults/XEphem
@${MKDIR} ${PREFIX}/lib/X11/xephem
${TAR} -C ${WRKSRC} -cf - auxil catalogs fits fifos tools \
| ${TAR} -C ${PREFIX}/lib/X11/xephem --unlink -xf -
- @find ${PREFIX}/lib/X11/xephem | xargs ${CHOWN} ${SHAREOWN}:${SHAREMODE}
- @find ${PREFIX}/lib/X11/xephem -type f | xargs ${CHMOD} ${SHAREMODE}
+ @${FIND} ${PREFIX}/lib/X11/xephem | ${XARGS} ${CHOWN} ${SHAREOWN}:${SHAREMODE}
+ @${FIND} ${PREFIX}/lib/X11/xephem -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
.include <bsd.port.mk>