summaryrefslogtreecommitdiff
path: root/astro/setiathome/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2003-06-01 05:45:34 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2003-06-01 05:45:34 +0000
commit044a2ff8cf2fd5f4864a3e696d549a7570d607d9 (patch)
tree279a3ec4d9ff546ca3ca7afbcd6a95c992ea2dd7 /astro/setiathome/Makefile
parent- Update to 1.1.0 (diff)
version bump to 3.08 w/ the following enhancements :
- only one master shell to monitor multiple setiathome instances - wait some time for setiathome server to come up between restarts - xsetiathome comes back - -graphics is now the default (so xsetiathome may be launched) - registration heuristic changed (see comments below) - take care, some variable names have changed (see comments below) - manual page reviewed The setiathome manual page refer to setiathome.conf while it is now named rc.setiathome.conf. also, the manual page has been completed (variables, start/stop scripts, etc.) - gracefull startup script option added Makefile PORTVERSION bumped PORTREVISION deleted FORBIDDEN deleted BROKEN bumped to 4.0 NO_XBIN deleted except for linux_base-6 wrapper added pkg-install registration heuristic changed (don't register if already registered, then automatically start setiathome in either case) pkg-list $FreeBSD$ added libexec/setiathome.bin added pkg-message FreeBSD 5.x a.out comment changed to FreeBSD 4.x comment files/rc.setiathome.conf seti_std_args defaulted to "-email -graphics" seti_proxy_args changed to seti_proxy_server seti_socks_server, seti_socks_user, seti_socks_passwd added seti_sleep changed to seti_sleep_time files/setiathome.1 /usr/local changed to %%PREFIX%% above and below changes described files/setiathome.sh same changes as files/rc.setiathome.conf don't start setiathome if already started su heuristic changed to call an external wrapper gracefull (aka apachectl :) option added using stop_after_send.txt PR: 50723,51759,52297,52709 Submitted by: cyrille.lefevre@laposte.net
Diffstat (limited to 'astro/setiathome/Makefile')
-rw-r--r--astro/setiathome/Makefile45
1 files changed, 21 insertions, 24 deletions
diff --git a/astro/setiathome/Makefile b/astro/setiathome/Makefile
index 171bf0498158..785e32430deb 100644
--- a/astro/setiathome/Makefile
+++ b/astro/setiathome/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= setiathome
-PORTVERSION?= 3.03
-PORTREVISION?= 7
+PORTVERSION?= 3.08
CATEGORIES?= astro
MASTER_SITES= ftp://ftp.cdrom.com/pub/setiathome/ \
ftp://alien.ssl.berkeley.edu/pub/
@@ -16,10 +15,6 @@ EXTRACT_SUFX= .tar
MAINTAINER?= cyrille.lefevre@laposte.net
COMMENT?= Donate idle cycles to the search for space aliens
-.if ${PORTVERSION} == "3.03"
-FORBIDDEN= 'Exploitable buffer overflow. http://spoor12.edup.tudelft.nl/'
-.endif
-
.include <bsd.port.pre.mk>
# Global variables
@@ -34,8 +29,8 @@ ONLY_FOR_ARCHS?= alpha i386
NO_BUILD= binary distribution
NO_CDROM= interactive install
-.if ${OSVERSION} <= 226000
-BROKEN= "currently supports only FreeBSD 2.2.6 and above"
+.if ${OSVERSION} < 400000
+BROKEN= "currently supports only FreeBSD 4.0 and above"
.endif
EXTRACT_CMD= ${CAT}
@@ -63,7 +58,7 @@ PORT_OSREL= v4.0d
.else
PORT_VENDOR?= unknown
PORT_OSNAME?= freebsd
-PORT_OSREL?= 2.2.8
+PORT_OSREL?= 4.0
.endif
PORT_OS= ${PORT_OSNAME}${PORT_OSREL}
PORT_HOST= ${PORT_CPU}-${PORT_VENDOR}-${PORT_OS}
@@ -82,15 +77,13 @@ DESCR= ${.CURDIR}/pkg-descr
.if !exists(${LINUXBASE}/usr/X11R6/lib/libXaw.so.7)
NO_XBIN= libXaw.so.7 is missing from linux_base-6
.endif
-NO_XBIN?= xsetiathome is broken
.endif
-.elif ${OSVERSION} >= 300000
-NO_XBIN= xsetiathome is broken
.endif
# Local variables
#
+LBIN_DIR= ${PREFIX}/libexec
SBIN_DIR= ${PREFIX}/sbin
CONF_DIR= ${PREFIX}/etc
RC_DIR= ${PREFIX}/etc/rc.d
@@ -100,18 +93,8 @@ SAMP_SUFX= .sample
BIN_FILE= setiathome
RC_FILES= setiathome
-# i386 NOTES:
-# xsetiathome is currently broken at 4.2. should work at 2.x,
-# don't know between 3.0 and 4.2 ? so, be conservative...
-# diagnostic messages are :
-# Warning: Cannot convert string "doneB" to type Widget
-# Floating point exception (core dumped)
# Linux NOTES:
# xsetiathome requires libXawk.so.7 which is missing from linux_base-6.
-# using linux_base-7, diagnostic messages are :
-# Warning: Cannot convert string "doneB" to type Widget
-# Shared memory segment doesn't exist. errno=2
-# Couldn't attach to the science process!
.if !defined(NO_XBIN)
MAN1+= x${PORTNAME}.1
@@ -125,7 +108,7 @@ X11PORTS= "@comment "
# Post-patch
#
-post-patch: patch-pkgmessage
+post-patch: patch-pkgmessage patch-man
patch-pkgmessage:
@${SED} 's|%%PREFIX%%|${PREFIX}|g; \
@@ -133,6 +116,16 @@ patch-pkgmessage:
s|%%SUFX%%|${PKGNAMESUFFIX}|g' \
${MSG_FILE} > ${PKGMESSAGE}
+patch-man:
+.for mansect in 1
+.for man in ${MAN${mansect}}
+ @${SED} 's|%%PREFIX%%|${PREFIX}|g; \
+ s|%%PREFX%%|${PKGNAMEPREFIX}|g; \
+ s|%%SUFX%%|${PKGNAMESUFFIX}|g' \
+ ${FILESDIR}/${man} > ${WRKDIR}/${man}
+.endfor
+.endfor
+
# Install
#
@@ -151,7 +144,7 @@ install-program:
install-man:
.for mansect in 1
.for man in ${MAN${mansect}}
- @${INSTALL_MAN} ${FILESDIR}/${man} \
+ @${INSTALL_MAN} ${WRKDIR}/${man} \
${MAN${mansect}PREFIX}/man/man${mansect}
.endfor
.endfor
@@ -178,6 +171,10 @@ install-startup-files:
@${INSTALL_SCRIPT} ${FILESDIR}/${file}.sh \
${RC_DIR}/${PKGNAMEPREFIX}${file}${PKGNAMESUFFIX}.sh
.endif
+.if exists(${FILESDIR}/${file}.bin)
+ @${INSTALL_SCRIPT} ${FILESDIR}/${file}.bin \
+ ${LBIN_DIR}/${PKGNAMEPREFIX}${file}${PKGNAMESUFFIX}.bin
+.endif
.endfor
configure-package: