summaryrefslogtreecommitdiff
path: root/astro/gdesklets-goodweather/Makefile
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2003-11-18 07:30:13 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2003-11-18 07:30:13 +0000
commite6c3c652aedb28861b67529fa2b168081f3314fc (patch)
treecbbf606b0b42fbd7f0c672d0e7fd8728ec2a7d7d /astro/gdesklets-goodweather/Makefile
parentA slave port for postgresql7, containing only the client interface. (diff)
Add gdesklets-goodweather, a gdesklet weather forecast thingy.
This desklet (sensor/display) shows the current temperature, humidity, sky, windchill temperature and a forecast of the next 4 days on your desktop. The data is retrieved from Weather XML Data Feed project at weather.com. The desklet is a hack based on the code of the original weather desklet, the Liquid Weather++ module for Karamba and some very nice artwork. PR: ports/59407 Submitted by: Jeremy Messenger <mezz7@cox.net>
Diffstat (limited to 'astro/gdesklets-goodweather/Makefile')
-rw-r--r--astro/gdesklets-goodweather/Makefile51
1 files changed, 51 insertions, 0 deletions
diff --git a/astro/gdesklets-goodweather/Makefile b/astro/gdesklets-goodweather/Makefile
new file mode 100644
index 000000000000..9075e07f50ba
--- /dev/null
+++ b/astro/gdesklets-goodweather/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: gdesklets-goodweather
+# Date created: 17 November 2003
+# Whom: Mezz <mezz7@cox.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= goodweather
+PORTVERSION= 0.1
+CATEGORIES= astro gnome
+MASTER_SITES= http://people.roqe.org/kr/misc/
+PKGNAMEPREFIX= gdesklets-
+DISTNAME= GoodWeather-${PORTVERSION}
+
+MAINTAINER= mezz7@cox.net
+COMMENT= A desklet that displays current weather condition and forecast
+
+RUN_DEPENDS= ${X11BASE}/libdata/pkgconfig/gdesklets-core.pc:${PORTSDIR}/deskutils/gdesklets
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+
+NAME= GoodWeather
+DATADIR= ${PREFIX}/share/gnome
+SKINS= liquid um weather.com
+
+do-build:
+ @${WRKSRC}/Install_${NAME}_Sensor.bin --nomsg ${WRKSRC}
+
+do-install:
+ @${MKDIR} ${DATADIR}/gdesklets/Displays/${NAME}/gfx
+.for ii in ${SKINS}
+ @${MKDIR} ${DATADIR}/gdesklets/Sensors/${NAME}/${ii}/large_icons
+ @${MKDIR} ${DATADIR}/gdesklets/Sensors/${NAME}/${ii}/small_icons
+ @${INSTALL_DATA} ${WRKSRC}/${NAME}/${ii}/large_icons/*.png \
+ ${DATADIR}/gdesklets/Sensors/${NAME}/${ii}/large_icons/
+ @${INSTALL_DATA} ${WRKSRC}/${NAME}/${ii}/small_icons/*.png \
+ ${DATADIR}/gdesklets/Sensors/${NAME}/${ii}/small_icons/
+.endfor
+ @${INSTALL_DATA} ${WRKSRC}/${NAME}/*.py ${DATADIR}/gdesklets/Sensors/${NAME}/
+ @${INSTALL_DATA} ${WRKSRC}/*.display ${DATADIR}/gdesklets/Displays/${NAME}/
+ @${INSTALL_DATA} ${WRKSRC}/gfx/*.png ${DATADIR}/gdesklets/Displays/${NAME}/gfx/
+ @${INSTALL_DATA} ${WRKSRC}/README ${DATADIR}/gdesklets/Displays/${NAME}/
+ @${LN} -s ${DATADIR}/gdesklets/Displays/${NAME}/README \
+ ${DATADIR}/gdesklets/Sensors/${NAME}/README
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>