summaryrefslogtreecommitdiff
path: root/astro/gdesklets-goodweather/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-03-13 20:04:24 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-03-13 20:04:24 +0000
commitde9f5ccabb5c228993be8785314846c03d88b286 (patch)
tree96bad9f3c08a5b08fd22c344c0d5d478f45f6c45 /astro/gdesklets-goodweather/Makefile
parentFix build with gtk+-2.4. (diff)
Change the method of pkg-message generation to fix potential breakage with
non-default paths. PR: 64066 Submitted by: maintainer
Diffstat (limited to 'astro/gdesklets-goodweather/Makefile')
-rw-r--r--astro/gdesklets-goodweather/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/astro/gdesklets-goodweather/Makefile b/astro/gdesklets-goodweather/Makefile
index c785e30bf58c..0ba052422a07 100644
--- a/astro/gdesklets-goodweather/Makefile
+++ b/astro/gdesklets-goodweather/Makefile
@@ -31,7 +31,6 @@ SKINS= liquid um weather.com
do-build:
@${WRKSRC}/Install_${NAME}_Sensor.bin --nomsg ${WRKSRC}
- @${CAT} pkg-message | ${SED} -e 's|%%PREFIX%%|${PREFIX}|g ; s|%%NAME%%|${NAME}|g' > ${PKGMESSAGE}
do-install:
@${MKDIR} ${DATADIR}/gdesklets/Displays/${NAME}/gfx
@@ -53,6 +52,8 @@ do-install:
post-install:
@${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${DATADIR}/gdesklets/Sensors/${NAME}
@${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${DATADIR}/gdesklets/Sensors/${NAME}
+ @${SED} -e 's|%%PREFIX%%|${PREFIX}|g ; s|%%NAME%%|${NAME}|g' \
+ ${FILESDIR}/pkg-message.in > ${PKGMESSAGE}
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>