summaryrefslogtreecommitdiff
path: root/astro/ephem/Makefile
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1997-06-03 09:14:13 +0000
committerSatoshi Asami <asami@FreeBSD.org>1997-06-03 09:14:13 +0000
commit7a509615924c7b68a2eb763e0c1d0c12195097c6 (patch)
tree9fbd0279c1ccc383dcc519a1ddda5bee97930105 /astro/ephem/Makefile
parentactivate nspmod (diff)
An interactive terminal-based ephemeris program. The source tarball is
in LOCAL_PORTS because those out on the 'net can't agree on the right size and include DOS executables and such. PR: 3407 Submitted by: Slaven Rezic <eserte@cs.tu-berlin.de>
Diffstat (limited to 'astro/ephem/Makefile')
-rw-r--r--astro/ephem/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/astro/ephem/Makefile b/astro/ephem/Makefile
new file mode 100644
index 000000000000..c5e916f6e1a8
--- /dev/null
+++ b/astro/ephem/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: ephem
+# Version required: 4.28
+# Date created: 3 April 1997
+# Whom: eserte
+#
+# $Id: $
+#
+
+DISTNAME= ephem_4.28_unix
+PKGNAME= ephem-4.28
+CATEGORIES= astro
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+
+MAINTAINER= eserte@cs.tu-berlin.de
+
+NO_WRKSUBDIR= yes
+NO_CONFIGURE= yes
+ALL_TARGET=
+
+CFLAGS+= -Wno-implicit
+
+do-install:
+ -cd ${WRKSRC}; \
+ ${INSTALL_PROGRAM} ephem ${PREFIX}/bin; \
+ ${MKDIR} ${PREFIX}/share/ephem; \
+ ${INSTALL_DATA} Man.txt ${PREFIX}/share/ephem/; \
+ [ ! -f ${PREFIX}/share/ephem/ephem.db ] && ${INSTALL_DATA} ephem.db ${PREFIX}/share/ephem/; \
+ [ ! -f ${PREFIX}/share/ephem/ephem.cfg ] && ${INSTALL_DATA} ephem.cfg ${PREFIX}/share/ephem/
+
+post-install:
+ @echo Don\'t forget to edit ${PREFIX}/share/ephem/ephem.cfg!
+
+.include <bsd.port.mk>