summaryrefslogtreecommitdiff
path: root/archivers/xmill/Makefile
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2003-05-09 19:03:17 +0000
committerMax Khon <fjoe@FreeBSD.org>2003-05-09 19:03:17 +0000
commit751000fc4323bb80f1546d65386a33d7bb875fb5 (patch)
tree998eead9745c7b33ca86dcc2614fa246774ea550 /archivers/xmill/Makefile
parentUpgrade to PyQT 3.5 (diff)
New port: xmill
An efficient compressor for XML. Submitted by: Alexey Dokuchaev
Diffstat (limited to 'archivers/xmill/Makefile')
-rw-r--r--archivers/xmill/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/archivers/xmill/Makefile b/archivers/xmill/Makefile
new file mode 100644
index 000000000000..769076eb1920
--- /dev/null
+++ b/archivers/xmill/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: xmill
+# Date created: 09 May 2003
+# Whom: Alexey Dokuchaev <danfe@regency.nsu.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmill
+PORTVERSION= 0.7
+CATEGORIES= archivers
+MASTER_SITES= http://www.research.att.com/~mff/XMILL/
+DISTNAME= xmill-0-7
+
+MAINTAINER= danfe@regency.nsu.ru
+COMMENT= An efficient compressor for XML
+
+NO_WRKSUBDIR= yes
+MAKEFILE= makefile
+
+USE_ZIP= yes
+
+.include <bsd.port.pre.mk>
+
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+IGNORE="Explicit agreement to the terms and conditions of the license required. Download ${DISTNAME}${EXTRACT_SUFX} manually from http://www.research.att.com/sw/tools/xmill/download.html, put it under ${DISTDIR} and run make again"
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/unix/xmill ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/unix/xdemill ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/unix/xbmill ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/unix/xbdemill ${PREFIX}/bin
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/COPYRIGHT.txt ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/LICENSE.txt ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/MANUAL.txt ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/paper/xmill.ps.gz ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>