summaryrefslogtreecommitdiff
path: root/accessibility/dasher/Makefile
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2005-08-28 17:22:13 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2005-08-28 17:22:13 +0000
commitbff2537a3ce42301179e9c7c7749a1b53a43869a (patch)
tree89a1fb1e0141679930b636005684d2563c5d2696 /accessibility/dasher/Makefile
parentCorrect PORTREVISIONs so that the overall PORTVERSION does not go (diff)
Update to 3.2.17.
Diffstat (limited to 'accessibility/dasher/Makefile')
-rw-r--r--accessibility/dasher/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/accessibility/dasher/Makefile b/accessibility/dasher/Makefile
index 494965962028..570f39ceb9fb 100644
--- a/accessibility/dasher/Makefile
+++ b/accessibility/dasher/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= dasher
-PORTVERSION= 3.2.15
+PORTVERSION= 3.2.17
CATEGORIES= accessibility editors x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/3.2
@@ -24,9 +24,10 @@ USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack intlhack gnomehier libgnomeui atspi \
libwnck
WANT_GNOME= yes
-USE_LIBTOOL_VER=15
+USE_INC_LIBTOOL_VER=15
INSTALLS_OMF= yes
USE_REINPLACE= yes
+USE_GCC= 3.4+
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -45,4 +46,14 @@ post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|-O2||g'
+patch-autotools:
+ @(cd ${PATCH_WRKSRC}; \
+ for file in ${LIBTOOLFILES}; do \
+ ${CP} $$file $$file.tmp; \
+ ${SED} -e "/^ltmain=/s^\$$ac_aux_dir/ltmain.sh^${LTMAIN}^g" \
+ $$file.tmp > $$file; \
+ ${RM} $$file.tmp; \
+ done);
+
+
.include <bsd.port.post.mk>