summaryrefslogtreecommitdiff
path: root/accessibility/dasher/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-04-30 00:47:21 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-04-30 00:47:21 +0000
commit798e9bed2a389dce8a970e15b68176fd49f442db (patch)
tree9dc5597aab073298ec381964f72cd853b3dd366c /accessibility/dasher/Makefile
parent- Update port 0.1.6 (diff)
Presenting GNOME 2.14.1 for FreeBSD! Checkout
http://www.gnome.org/start/2.14/ for the official release notes, and a list of all the gooides in this new release. In particular, GNOME 2.14 focused on performance, and they did not miss the mark. There's some new eye candy, but most of the big things are waiting until GNOME 2.16. On the FreeBSD side, we tried to clean up all the crashers we could. In particular, we really improved GNOME's 64-bit support. The good news is that this release does not bring any big shared library version bumps, so you can almost do a simple portupgrade to get to 2.14. There are a few minor gotchas that will be documented in UPDATING shortly. The FreeBSD GNOME Team would like th thank the following users for their patches, feedback, and sometimes incessant complaing about crashes (you know who you are). Yasuda Keisuke <kysd@po.harenet.ne.jp> Pascal Hofstee <caelian@gmail.com> rmgls@wanadoo.fr tmclaugh Yuri Pankov <yuri.pankov@gmail.com> sajd on #freebsd-gnome ade ankon on #FreeBSD-Gnome mux Pascal Hofstee <caelian@gmail.com> QuiRK on #freebsd-gnome Vladimir Timofeev <vovkasm@gmail.com>
Diffstat (limited to 'accessibility/dasher/Makefile')
-rw-r--r--accessibility/dasher/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/accessibility/dasher/Makefile b/accessibility/dasher/Makefile
index 445df1ae2890..df97a89f56dd 100644
--- a/accessibility/dasher/Makefile
+++ b/accessibility/dasher/Makefile
@@ -3,26 +3,25 @@
# Whom: lewiz <purple@lewiz.net>
#
# $FreeBSD$
-# $MCom: ports/accessibility/dasher/Makefile,v 1.18 2005/10/29 22:31:15 marcus Exp $
+# $MCom: ports/accessibility/dasher/Makefile,v 1.34 2006/04/13 07:52:29 bland Exp $
#
PORTNAME= dasher
-PORTVERSION= 3.2.18
-PORTREVISION= 1
+PORTVERSION= 4.0.2
PORTEPOCH= 1
CATEGORIES= accessibility editors x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/3.2
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
DIST_SUBDIR= gnome2
MAINTAINER= lewiz@compsoc.man.ac.uk
COMMENT= Information efficient text-entry interface
BUILD_DEPENDS= scrollkeeper-config:${PORTSDIR}/textproc/scrollkeeper
-LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
RUN_DEPENDS= scrollkeeper-config:${PORTSDIR}/textproc/scrollkeeper
USE_BZIP2= yes
+USE_GETTEXT= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack intlhack gnomehier libgnomeui atspi \
@@ -30,7 +29,7 @@ USE_GNOME= gnomeprefix gnomehack intlhack gnomehier libgnomeui atspi \
WANT_GNOME= yes
GNU_CONFIGURE= yes
INSTALLS_OMF= yes
-USE_REINPLACE= yes
+INSTALLS_ICONS= yes
USE_GCC= 3.4+
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -41,8 +40,7 @@ MAN1= dasher.1
.if ${HAVE_GNOME:Mgnomespeech}!=""
USE_GNOME+= gnomespeech
-.else
-CONFIGURE_ARGS+=--without-speech
+CONFIGURE_ARGS+=--enable-speech
.endif
post-patch: