summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2022-03-15 20:37:10 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2022-03-15 20:37:10 +0000
commit4f01cdbb1640a101246a5224acfa8f1270aae166 (patch)
treee818b3463107419fb17bf7cb389535a66380c465
parentdevel/qtcreator: update to 6.0.2, cmake build (diff)
lang/algol68g: update Algol 68 Genie to version 3.0.6, hook the tests
This new release is mostly the result of the evolution of the previous version over the [five] years. Since the hardware representation of several modes has changed, the version number has been incremented. Former Algol 68 Genie versions 1 and 2 implement 32-bit INT, BITS and 64-bit REAL modes, while implementing all LONG and LONG LONG modes in software. Version 3 implements 64-bit INT, REAL and BITS modes, and 128-bit LONG modes which are supported by modern processors; only LONG LONG modes remain implemented in software. Version 3.0 offers bindings for more functions from the GNU Scientific Library, as well as for statistical routines from the GNU R stand-alone mathematics library, and adds a generalized incomplete gamma function according a recent algorithm by Abergel and Moisan from the University of Paris. Also, it incorporates reported bugfixes. While here, drop CONFIGURE_ARGS+=--enable-compiler as it is enabled by default, and switch to dedicated pkg-plist now that there are 36 files.
-rw-r--r--lang/algol68g/Makefile24
-rw-r--r--lang/algol68g/distinfo6
-rw-r--r--lang/algol68g/pkg-plist36
3 files changed, 52 insertions, 14 deletions
diff --git a/lang/algol68g/Makefile b/lang/algol68g/Makefile
index 9ca5159509bc..08335cb79456 100644
--- a/lang/algol68g/Makefile
+++ b/lang/algol68g/Makefile
@@ -1,6 +1,5 @@
PORTNAME= algol68g
-PORTVERSION= 2.8.4
-PORTREVISION= 10
+PORTVERSION= 3.0.6
CATEGORIES= lang
MASTER_SITES= http://jmvdveer.home.xs4all.nl/
@@ -9,10 +8,16 @@ COMMENT= Algol 68 Genie compiler
LICENSE= GPLv3+
-LIB_DEPENDS= libgsl.so:math/gsl
+USES= readline
+GNU_CONFIGURE= yes
+TEST_TARGET= check
+
+OPTIONS_DEFINE= GSL PGSQL PLOTUTILS RMATH
+OPTIONS_DEFAULT= GSL PGSQL PLOTUTILS RMATH
-OPTIONS_DEFINE= PLOTUTILS PGSQL
-OPTIONS_DEFAULT=PLOTUTILS PGSQL
+GSL_DESC= Bindings for GNU Scientific Library
+GSL_LIB_DEPENDS= libgsl.so:math/gsl
+GSL_CONFIGURE_ENABLE= gsl
PLOTUTILS_DESC= Plotting support via plotutils
PLOTUTILS_LIB_DEPENDS= libplot.so:graphics/plotutils
@@ -21,12 +26,9 @@ PLOTUTILS_CONFIGURE_ENABLE=plotutils
PGSQL_USES= pgsql
PGSQL_CONFIGURE_ENABLE= postgresql
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--enable-compiler
-USES= readline
-
-PLIST_FILES= bin/a68g man/man1/a68g.1.gz \
- include/algol68g/a68g.h include/algol68g/a68g-config.h
+RMATH_DESC= Bindings for GNU R's statistical routines
+RMATH_LIB_DEPENDS= libRmath.so:math/libRmath
+RMATH_CONFIGURE_ENABLE= mathlib
post-patch:
# Skip broken check, assume our $CC works
diff --git a/lang/algol68g/distinfo b/lang/algol68g/distinfo
index 83e1b7179f1c..d85764cb6e8c 100644
--- a/lang/algol68g/distinfo
+++ b/lang/algol68g/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1479242155
-SHA256 (algol68g-2.8.4.tar.gz) = 5823ccd0c18fe10a368a117cc3924748c4a5d0fe8dff0d9d818ff73c342565f0
-SIZE (algol68g-2.8.4.tar.gz) = 516697
+TIMESTAMP = 1647118993
+SHA256 (algol68g-3.0.6.tar.gz) = d407b36c4b5e984a63b24125d4a13f34771bebb65d55058375d85ddb0ac31b5b
+SIZE (algol68g-3.0.6.tar.gz) = 621615
diff --git a/lang/algol68g/pkg-plist b/lang/algol68g/pkg-plist
new file mode 100644
index 000000000000..ec418a929e2b
--- /dev/null
+++ b/lang/algol68g/pkg-plist
@@ -0,0 +1,36 @@
+bin/a68g
+include/algol68g/a68g-common.h
+include/algol68g/a68g-compiler.h
+include/algol68g/a68g-config.h
+include/algol68g/a68g-defines.h
+include/algol68g/a68g-diagnostics.h
+include/algol68g/a68g-double.h
+include/algol68g/a68g-enums.h
+include/algol68g/a68g-environ.h
+include/algol68g/a68g-frames.h
+include/algol68g/a68g-generic.h
+include/algol68g/a68g-genie.h
+include/algol68g/a68g-includes.h
+include/algol68g/a68g-level-3.h
+include/algol68g/a68g-lib.h
+include/algol68g/a68g-listing.h
+include/algol68g/a68g-masks.h
+include/algol68g/a68g-math.h
+include/algol68g/a68g-mp.h
+include/algol68g/a68g-nil.h
+include/algol68g/a68g-numbers.h
+include/algol68g/a68g-optimiser.h
+include/algol68g/a68g-options.h
+include/algol68g/a68g-parser.h
+include/algol68g/a68g-physics.h
+include/algol68g/a68g-platform.h
+include/algol68g/a68g-postulates.h
+include/algol68g/a68g-prelude-gsl.h
+include/algol68g/a68g-prelude-mathlib.h
+include/algol68g/a68g-prelude.h
+include/algol68g/a68g-stack.h
+include/algol68g/a68g-stddef.h
+include/algol68g/a68g-transput.h
+include/algol68g/a68g-types.h
+include/algol68g/a68g.h
+man/man1/a68g.1.gz