summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-01-08 17:36:07 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2004-01-08 17:36:07 +0000
commitf8e4e0cf2e3f432ad168d63a234b9199c3f5d5d7 (patch)
tree5eaba1ded87b03c292d389957c6ddfd4470f7116
parentAdd IPv6 support via the Kame 317-v6-20040108b patch. (diff)
- Warn about conflict with /lib/libcrypto.so
-rw-r--r--security/openssl-beta/Makefile10
-rw-r--r--security/openssl/Makefile10
2 files changed, 20 insertions, 0 deletions
diff --git a/security/openssl-beta/Makefile b/security/openssl-beta/Makefile
index aa128d762118..3db3c2173dfa 100644
--- a/security/openssl-beta/Makefile
+++ b/security/openssl-beta/Makefile
@@ -850,6 +850,16 @@ INSTALLS_SHLIB= yes
.endif
.if defined(OPENSSL_OVERWRITE_BASE)
+.if exists(/lib/libcrypto.so)
+pre-everything::
+ @${ECHO_CMD} "#"
+ @${ECHO_CMD} "# this ports does not support the dynamic root"
+ @${ECHO_CMD} "# please undefine OPENSSL_OVERWRITE_BASE"
+ @${ECHO_CMD} "# and use WITH_OPENSSL_PORT=yes instead."
+ @${ECHO_CMD} "#"
+ @${FALSE}
+
+.endif
PKGNAMESUFFIX= -beta-overwrite-base
PREFIX= /usr
OPENSSLDIR= /etc/ssl
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 402e7d85fa3b..b502e22bab66 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -834,6 +834,16 @@ INSTALLS_SHLIB= yes
.endif
.if defined(OPENSSL_OVERWRITE_BASE)
+.if exists(/lib/libcrypto.so)
+pre-everything::
+ @${ECHO_CMD} "#"
+ @${ECHO_CMD} "# this ports does not support the dynamic root"
+ @${ECHO_CMD} "# please undefine OPENSSL_OVERWRITE_BASE"
+ @${ECHO_CMD} "# and use WITH_OPENSSL_PORT=yes instead."
+ @${ECHO_CMD} "#"
+ @${FALSE}
+
+.endif
PKGNAMESUFFIX= -overwrite-base
PREFIX= /usr
OPENSSLDIR= /etc/ssl