summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-07-24 22:29:33 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-07-24 22:29:33 +0000
commite314a0d3c424c7ae89295e39c81d7a267566cf43 (patch)
treeccbf0b464b9a8025b224d655b80ad7363c58b944
parentFix pkg-plist. (diff)
- Add CC and CXX to MAKE_ENV for all ports
PR: ports/86106, ports/101120 (based on)
-rw-r--r--Mk/bsd.gcc.mk2
-rw-r--r--Mk/bsd.port.mk5
-rw-r--r--games/formido/Makefile3
-rw-r--r--graphics/gdal/files/patch-swig-python-GNUmakefile2
-rw-r--r--x11-toolkits/xmhtml/Makefile2
-rw-r--r--x11-wm/sapphire/Makefile2
6 files changed, 8 insertions, 8 deletions
diff --git a/Mk/bsd.gcc.mk b/Mk/bsd.gcc.mk
index 7fad94aa145b..793091fb87e6 100644
--- a/Mk/bsd.gcc.mk
+++ b/Mk/bsd.gcc.mk
@@ -196,8 +196,6 @@ CXX:= g++${V}
BUILD_DEPENDS+= ${_GCC_PORT_DEPENDS}:${PORTSDIR}/lang/${_GCC_BUILD_DEPENDS}
.endif
-MAKE_ENV+= CC="${CC}" CXX="${CXX}" CFLAGS="${CFLAGS}"
-
.endif
# defined(USE_GCC)
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 7c1750f0beb2..6466a3e83866 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -2091,8 +2091,9 @@ MAKE_FLAGS?= -f
MAKEFILE?= Makefile
MAKE_ENV+= PREFIX=${PREFIX} \
LOCALBASE=${LOCALBASE} X11BASE=${X11BASE} \
- MOTIFLIB="${MOTIFLIB}" LIBDIR="${LIBDIR}" CFLAGS="${CFLAGS}" \
- CXXFLAGS="${CXXFLAGS}" MANPREFIX="${MANPREFIX}"
+ MOTIFLIB="${MOTIFLIB}" LIBDIR="${LIBDIR}" \
+ CC="${CC}" CFLAGS="${CFLAGS}" CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" \
+ MANPREFIX="${MANPREFIX}"
# Add -fno-strict-aliasing to CFLAGS with optimization level -O2 or higher.
# gcc 4.x enable strict aliasing optimization with -O2 which is known to break
diff --git a/games/formido/Makefile b/games/formido/Makefile
index 8f71b5c4218f..8cd7d0e4f21d 100644
--- a/games/formido/Makefile
+++ b/games/formido/Makefile
@@ -21,8 +21,9 @@ USE_SDL= sdl mixer image
HISCOREDIR= /var/games/formido
+CC= ${CXX}
MAKE_ENV= DATDIR="${DATADIR}" HISCOREDIR="${HISCOREDIR}" \
- CC="${CXX}" LINKFLAGS="${CXXFLAGS}" DEFAULT_CONFIG_FILE="${DATADIR}/formido.cfg"
+ LINKFLAGS="${CXXFLAGS}" DEFAULT_CONFIG_FILE="${DATADIR}/formido.cfg"
OPTIONS= MUSIC "Install music (6MB)" on
diff --git a/graphics/gdal/files/patch-swig-python-GNUmakefile b/graphics/gdal/files/patch-swig-python-GNUmakefile
index f00331fae35a..04988668b7ba 100644
--- a/graphics/gdal/files/patch-swig-python-GNUmakefile
+++ b/graphics/gdal/files/patch-swig-python-GNUmakefile
@@ -5,7 +5,7 @@
build:
- python setup.py build
-+ python setup.py bdist_egg
++ CXX="" python setup.py bdist_egg
egg:
python setup.py bdist_egg
diff --git a/x11-toolkits/xmhtml/Makefile b/x11-toolkits/xmhtml/Makefile
index 69694320ec38..8259148224ad 100644
--- a/x11-toolkits/xmhtml/Makefile
+++ b/x11-toolkits/xmhtml/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
USE_AUTOTOOLS= libtool:15:env
USE_MOTIF= yes
USE_GMAKE= yes
-MAKE_ENV= CC="${LIBTOOL} ${CC}"
+CC:= ${LIBTOOL} ${CC}
USE_LDCONFIG= yes
do-configure:
diff --git a/x11-wm/sapphire/Makefile b/x11-wm/sapphire/Makefile
index 309f0d9ae33c..edf5e8bb9b18 100644
--- a/x11-wm/sapphire/Makefile
+++ b/x11-wm/sapphire/Makefile
@@ -17,7 +17,7 @@ COMMENT= Small window manager
USE_XORG= x11 xext
USE_GMAKE= yes
REINPLACE_ARGS= -i '' -e
-MAKE_ENV= CC="${CXX}"
+CC= ${CXX}
post-extract: