summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2004-12-13 23:57:45 +0000
committerHerve Quiroz <hq@FreeBSD.org>2004-12-13 23:57:45 +0000
commite1aefd548ff484ae639ffccd123e860a7541889d (patch)
treeb68c1b879ec938f439c1f61181741dbefe2e3dd0
parent- Update to 1.0.1 (diff)
- Update to 4.2.0
- Use %%JAVAJARDIR%% - ECHO_CMD -> ECHO_MSG - Use INSTALL_DATA to install JAR files and documentation files NOTE: the port now installs three different JAR files: - avalon-framework-api.jar: API classes and interfaces - avalon-framework-impl.jar: Implementation classes - avalon-framework.jar: Full package (the former installed JAR) Requested by: Manfred N. Riem <mnriem@earthlink.net>
-rw-r--r--devel/avalon-framework/Makefile41
-rw-r--r--devel/avalon-framework/distinfo4
2 files changed, 22 insertions, 23 deletions
diff --git a/devel/avalon-framework/Makefile b/devel/avalon-framework/Makefile
index 6c25f4d95fae..f1120c279153 100644
--- a/devel/avalon-framework/Makefile
+++ b/devel/avalon-framework/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= avalon-framework
-PORTVERSION= 4.1.5
+PORTVERSION= 4.2.0
CATEGORIES= devel java
MASTER_SITES= ${MASTER_SITE_APACHE}
-MASTER_SITE_SUBDIR= avalon/avalon-framework/binaries/
+MASTER_SITE_SUBDIR= avalon/${PORTNAME}/binaries/
MAINTAINER= hq@FreeBSD.org
COMMENT= Apache Avalon core framework for component programming
@@ -21,29 +21,28 @@ NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
.if !defined(NOPORTDOCS)
-PORTDOCS= api basics.html changelog-report.html cop cvs-usage.html \
- dependencies.html developer-activity-report.html \
- file-activity-report.html images index.html \
- issue-tracking.html license.html mail-lists.html \
- maven-reports.html principals project-info.html style \
- team-list.html
+PORTDOCS= api basics.html cop cvs-usage.html dependencies.html images \
+ index.html issue-tracking.html license.html linkcheck.html \
+ mail-lists.html maven-reports.html principals \
+ project-info.html style team-list.html
.endif
-JARFILE= ${DISTNAME}.jar
-DESTJARFILE= ${PORTNAME}.jar
-PLIST_FILES+= ${JAVAJARDIR:S,^${PREFIX}/,,}/${DESTJARFILE}
+
+JARFILES= ${PORTNAME}.jar ${PORTNAME}-api.jar ${PORTNAME}-impl.jar
+PLIST_FILES+= ${JARFILES:S,^,%%JAVAJARDIR%%/,}
do-install:
- @${ECHO_CMD} -n ">> Installing JAR as ${JAVAJARDIR}/${DESTJARFILE}..."
- @${CP} ${WRKSRC}/${JARFILE} ${JAVAJARDIR}/${DESTJARFILE}
- @${ECHO_CMD} " [ DONE ]"
-.if !defined(NOPORTDOCS)
- @${ECHO_CMD} -n ">> Installing documentation in ${DOCSDIR}..."
- @${MKDIR} ${DOCSDIR}
-.for DOCFILE in ${PORTDOCS}
- @${CP} -r ${WRKSRC}/docs/${DOCFILE} ${DOCSDIR}/
- @${ECHO_CMD} -n " ${DOCFILE}"
+ @${ECHO_MSG} -n ">> Installing JARs in ${JAVAJARDIR}/..."
+.for jarfile in ${JARFILES}
+ @${ECHO_MSG} -n " ${jarfile}"
+ @${INSTALL_DATA} ${WRKSRC}/jars/${jarfile:S,.jar$,-${PORTVERSION}.jar,} ${JAVAJARDIR}/${jarfile}
.endfor
- @${ECHO_CMD} " [ DONE ]"
+ @${ECHO_MSG} " [ DONE ]"
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}..."
+ @cd ${WRKSRC}/docs \
+ && ${FIND} ${PORTDOCS} -type d -exec ${MKDIR} ${DOCSDIR}/{} \; \
+ && ${FIND} ${PORTDOCS} -type f -exec ${INSTALL_DATA} {} ${DOCSDIR}/{} \;
+ @${ECHO_MSG} " [ DONE ]"
.endif
.include <bsd.port.mk>
diff --git a/devel/avalon-framework/distinfo b/devel/avalon-framework/distinfo
index 5a6bd7c3b9ba..dd839a7a4a44 100644
--- a/devel/avalon-framework/distinfo
+++ b/devel/avalon-framework/distinfo
@@ -1,2 +1,2 @@
-MD5 (avalon-framework-4.1.5.tar.gz) = 2111d1c9dcce5beecef04d8bb66b8b65
-SIZE (avalon-framework-4.1.5.tar.gz) = 394814
+MD5 (avalon-framework-4.2.0.tar.gz) = 8ff312175554a7199769fad71a04cde4
+SIZE (avalon-framework-4.2.0.tar.gz) = 439302