summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-06-01 15:01:47 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-06-01 15:01:47 +0000
commitd600782850575aa160309300c62af7a1feffe4db (patch)
tree472a184f6490c9fa6bb295a89c8dd868f0b91a3a
parent- Fix handling of files with '$' sign in name (diff)
Add MapServer, a system for developing web-based GIS applications.
The basic system consists of a CGI program that can be configured to respond to a variety of spatial requests like making maps, scalebars, and point, area and feature queries. Virtually all aspects of an application, from web interface to map appearance can be developed without any programming. For the more ambitious user, MapServer applications can be enhanced using Java, JavaScript or many other web technologies. PR: ports/67387 Submitted by: Douglas K. Rand <rand@meridian-enviro.com>
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/mapserver/Makefile72
-rw-r--r--graphics/mapserver/distinfo2
-rw-r--r--graphics/mapserver/pkg-descr10
-rw-r--r--graphics/mapserver/pkg-plist10
5 files changed, 95 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 98e0d6549327..ccf3f89819d6 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -246,6 +246,7 @@
SUBDIR += linux_glx
SUBDIR += linux_mesa3
SUBDIR += lodju
+ SUBDIR += mapserver
SUBDIR += maverik
SUBDIR += megapov
SUBDIR += mesa-demos
diff --git a/graphics/mapserver/Makefile b/graphics/mapserver/Makefile
new file mode 100644
index 000000000000..49066557027f
--- /dev/null
+++ b/graphics/mapserver/Makefile
@@ -0,0 +1,72 @@
+# New ports collection Makefile for: mapserver
+# Date created: 2004-05-20
+# Whom: Douglas K. Rand <rand@meridian-enviro.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mapserver
+PORTVERSION= 4.0.2
+CATEGORIES= graphics www misc
+MASTER_SITES= http://cvs.gis.umn.edu/dist/
+
+MAINTAINER= rand@meridian-enviro.com
+COMMENT= System for developing web-based GIS applications
+
+LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd \
+ proj.3:${PORTSDIR}/graphics/proj
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-runpath \
+ --with-gd=${LOCALBASE} \
+ --with-proj=${LOCALBASE}
+
+.if defined(WITH_TIFF)
+LIB_DEPENDS+= tiff.4:${PORTSDIR}/graphics/tiff
+CONFIGURE_ARGS+= --with-tiff=${LOCALBASE}
+.endif
+
+.if defined(WITH_MING)
+LIB_DEPENDS+= ming.3:${PORTSDIR}/graphics/ming
+CONFIGURE_ARGS+= --with-ming=${LOCALBASE}
+.endif
+
+.if defined(WITH_PDF)
+LIB_DEPENDS+= pdf.6:${PORTSDIR}/graphics/pdflib
+CONFIGURE_ARGS+= --with-pdf=${LOCALBASE}
+.endif
+
+.if defined(WITH_WMS)
+LIB_DEPENDS+= curl.2:${PORTSDIR}/ftp/curl
+CONFIGURE_ARGS+= --wmsclient
+.endif
+
+.if defined(WITH_GDAL)
+LIB_DEPENDS+= gdal.1.1:${PORTSDIR}/graphics/gdal
+CONFIGURE_ARGS+= --with-gdal=${LOCALBASE}
+.endif
+
+.if defined(WITH_POSTGRESQL)
+POSTGRESQL_PORT?= databases/postgresql-client
+LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
+CONFIGURE_ARGS+= --with-postgis=${LOCALBASE}/bin/pg_config
+.endif
+
+.if defined(WITH_PHP)
+BUILD_DEPENDS+= mod_php4:${PORTSDIR}/www/mod_php4:
+CONFIGURE_ARGS+= --with-php=${LOCALBASE}
+.endif
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-debug
+.endif
+
+PROG_FILES= mapserv legend scalebar shp2img shp2pdf shptree shptreetst shptreevis sortshp
+
+do-install:
+.for f in ${PROG_FILES}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${LOCALBASE}/bin
+.endfor
+ ${INSTALL_SCRIPT} ${WRKSRC}/shp2mysql.pl ${LOCALBASE}/bin/shp2mysql
+
+.include <bsd.port.mk>
diff --git a/graphics/mapserver/distinfo b/graphics/mapserver/distinfo
new file mode 100644
index 000000000000..068b7f69d4ee
--- /dev/null
+++ b/graphics/mapserver/distinfo
@@ -0,0 +1,2 @@
+MD5 (mapserver-4.0.2.tar.gz) = 757ea220ae04aabc44c739682df3d0e4
+SIZE (mapserver-4.0.2.tar.gz) = 868993
diff --git a/graphics/mapserver/pkg-descr b/graphics/mapserver/pkg-descr
new file mode 100644
index 000000000000..c4aec99aca81
--- /dev/null
+++ b/graphics/mapserver/pkg-descr
@@ -0,0 +1,10 @@
+MapServer is a system for developing web-based GIS applications.
+The basic system consists of a CGI program that can be configured to
+respond to a variety of spatial requests like making maps, scalebars,
+and point, area and feature queries. Virtually all aspects of an
+application, from web interface to map appearance can be developed
+without any programming. For the more ambitious user, MapServer
+applications can be enhanced using Java, JavaScript or many other web
+technologies.
+
+WWW: http://mapserver.gis.umn.edu/
diff --git a/graphics/mapserver/pkg-plist b/graphics/mapserver/pkg-plist
new file mode 100644
index 000000000000..a3e1952d9d12
--- /dev/null
+++ b/graphics/mapserver/pkg-plist
@@ -0,0 +1,10 @@
+bin/mapserv
+bin/legend
+bin/scalebar
+bin/shp2img
+bin/shp2mysql
+bin/shp2pdf
+bin/shptree
+bin/shptreetst
+bin/shptreevis
+bin/sortshp