summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2013-10-09 08:01:13 +0000
committerJason E. Hale <jhale@FreeBSD.org>2013-10-09 08:01:13 +0000
commitcc1292b873f6f77fb574cdefff7a4c225208adf9 (patch)
tree6776cb183a0064bf0aaade11b207d92963c09361
parent- Use unique package names (diff)
- Support staging
- Use new LIB_DEPENDS syntax
-rw-r--r--audio/libofa/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/audio/libofa/Makefile b/audio/libofa/Makefile
index ec43e61d92c5..d70d57ea3262 100644
--- a/audio/libofa/Makefile
+++ b/audio/libofa/Makefile
@@ -17,15 +17,14 @@ LICENSE_NAME_APL1= Adaptive Public License version 1.0
LICENSE_FILE_APL1= ${WRKSRC}/COPYING
LICENSE_PERMS_APL1= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-LIB_DEPENDS= fftw3:${PORTSDIR}/math/fftw3 \
- expat:${PORTSDIR}/textproc/expat2 \
- curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS= libfftw3.so:${PORTSDIR}/math/fftw3 \
+ libexpat.so:${PORTSDIR}/textproc/expat2 \
+ libcurl.so:${PORTSDIR}/ftp/curl
PROJECTHOST= musicip-libofa
USE_DOS2UNIX= yes
-NO_STAGE= yes
USE_AUTOTOOLS= libtool
-USES= pathfix
+USES= pathfix
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib