summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2004-01-29 17:37:57 +0000
committerCy Schubert <cy@FreeBSD.org>2004-01-29 17:37:57 +0000
commitc84de390ec8fd41dadb2cb2c8393d0f1ae0f1267 (patch)
tree7d20a1348ffb22441ef52a1bc8d45c54495553b4
parentUpdate to 3.1.0 (diff)
1. Update 1.0.3 --> 1.3-rc7
2. Update master site list 3. As 5.x already ships with it's own pam_krb5, configure the port to only install on 4.x systems.
-rw-r--r--security/pam_krb5/Makefile35
-rw-r--r--security/pam_krb5/distinfo2
-rw-r--r--security/pam_krb5/files/patch-configure11
-rw-r--r--security/pam_krb5/files/patch-pam_krb5_sess.c12
-rw-r--r--security/pam_krb5/files/patch-pam_krb5afs.c10
-rw-r--r--security/pam_krb5/pkg-plist2
6 files changed, 48 insertions, 24 deletions
diff --git a/security/pam_krb5/Makefile b/security/pam_krb5/Makefile
index 7a20ec6d6688..35fcf9191c5e 100644
--- a/security/pam_krb5/Makefile
+++ b/security/pam_krb5/Makefile
@@ -6,18 +6,30 @@
#
PORTNAME= pam_krb5
-PORTVERSION= 1.0.3
+PORTVERSION= 1.3.r7
CATEGORIES= security
-MASTER_SITES= http://www.komquats.com/distfiles/
+MASTER_SITES= http://unc.dl.sourceforge.net/sourceforge/pam-krb5/ \
+ http://umn.dl.sourceforge.net/sourceforge/pam-krb5/ \
+ http://twtelecom.dl.sourceforge.net/sourceforge/pam-krb5/ \
+ http://aleron.dl.sourceforge.net/sourceforge/pam-krb5/ \
+ http://easynews.dl.sourceforge.net/sourceforge/pam-krb5/ \
+ http://switch.dl.sourceforge.net/sourceforge/pam-krb5/ \
+ http://cesnet.dl.sourceforge.net/sourceforge/pam-krb5/ \
+ http://flow.dl.sourceforge.net/sourceforge/pam-krb5/ \
+ http://easynews.dl.sourceforge.net/sourceforge/pam-krb5/ \
+ http://keihanna.dl.sourceforge.net/sourceforge/pam-krb5/ \
+ http://heanet.dl.sourceforge.net/sourceforge/pam-krb5/ \
+ http://www.komquats.com/distfiles/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/-rc/}
MAINTAINER= cy@FreeBSD.org
COMMENT= A Pluggable Authentication Module for Kerberos 5
MAN8= pam_krb5.8
-USE_BZIP2= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
+USE_GMAKE= yes
.if defined(PACKAGE_BUILDING)
KRB5_IMPL= mit
@@ -37,21 +49,24 @@ KRB5_DIR?= ${KRB5_HOME}
BROKEN= You must define KRB5_IMPL to be \"mit\" or \"heimdal\"
.endif
-.if defined(PREFIX)
-MANDIR= ${PREFIX}/man
-.else
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500000
+BROKEN= FreeBSD 5.x already ships with its own version of pam_krb5
+.endif
+MANDIR= ${MANPREFIX}/man
PREFIX= ${DESTDIR}/usr
MANPREFIX= ${DESTDIR}/usr/share
MANDIR= ${PREFIX}/share/man
-.endif
KRB5_DIR?= ${LOCALBASE}
CONFIGURE_ENV= CFLAGS="${CFLAGS}"
CONFIGURE_ARGS= --with-krb5="${KRB5_DIR}" \
--with-pamdir="${PREFIX}/lib" \
--with-man-sect=8 \
- --mandir=${MANDIR}
+ --mandir=${MANDIR} \
+ --without-krbafs
post-install:
- cd ${WRKSRC} && ${MAKE} install-man
+ cd ${WRKSRC} && ${GMAKE} install-man
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/pam_krb5/distinfo b/security/pam_krb5/distinfo
index d4ca0cefe37e..159607ae4676 100644
--- a/security/pam_krb5/distinfo
+++ b/security/pam_krb5/distinfo
@@ -1 +1 @@
-MD5 (pam_krb5-1.0.3.tar.bz2) = 9a3b26dc8a52e9882bdaf41f8e50d721
+MD5 (pam_krb5-1.3-rc7.tar.gz) = 2c7c8974604e5c325bb2e62d0066cdce
diff --git a/security/pam_krb5/files/patch-configure b/security/pam_krb5/files/patch-configure
new file mode 100644
index 000000000000..3b3d21cf4293
--- /dev/null
+++ b/security/pam_krb5/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Mon Mar 17 09:31:46 2003
++++ configure Wed Jan 21 15:26:38 2004
+@@ -11043,7 +11043,7 @@
+ # Check whether --with-krbafs or --without-krbafs was given.
+ if test "${with_krbafs+set}" = set; then
+ withval="$with_krbafs"
+- if test x$withval != xyes ; then
++ if test x$withval != xyes -a x$withval != xno; then
+ KRBAFS=$withval
+ CPPFLAGS="-I$withval/include $CPPFLAGS"
+ CFLAGS="-I$withval/include $CFLAGS"
diff --git a/security/pam_krb5/files/patch-pam_krb5_sess.c b/security/pam_krb5/files/patch-pam_krb5_sess.c
deleted file mode 100644
index c16b06f9c84a..000000000000
--- a/security/pam_krb5/files/patch-pam_krb5_sess.c
+++ /dev/null
@@ -1,12 +0,0 @@
-*** pam_krb5_sess.c.orig Sat Sep 7 10:42:40 2002
---- pam_krb5_sess.c Sat Sep 7 10:43:02 2002
-***************
-*** 9,14 ****
---- 9,15 ----
- static const char rcsid[] = "$Id: pam_krb5_sess.c,v 1.1.1.1.2.5 2001/09/24 14:58:15 nectar Exp $";
-
- #include <krb5.h>
-+ #include <syslog.h>
- #include "pam_krb5.h"
-
- /* Initiate session management */
diff --git a/security/pam_krb5/files/patch-pam_krb5afs.c b/security/pam_krb5/files/patch-pam_krb5afs.c
new file mode 100644
index 000000000000..545fdded8fec
--- /dev/null
+++ b/security/pam_krb5/files/patch-pam_krb5afs.c
@@ -0,0 +1,10 @@
+--- pam_krb5afs.c.orig Mon Mar 10 15:37:00 2003
++++ pam_krb5afs.c Wed Jan 21 15:19:16 2004
+@@ -108,7 +108,6 @@
+ #define MODULE_RET_NAME MODULE_NAME "_ret_stash"
+
+ #define PAM_SM_AUTH
+-#define PAM_SM_ACCT_MGMT
+ #define PAM_SM_SESSION
+ #define PAM_SM_PASSWORD
+
diff --git a/security/pam_krb5/pkg-plist b/security/pam_krb5/pkg-plist
index 2c1938c01a42..25d2429ddd31 100644
--- a/security/pam_krb5/pkg-plist
+++ b/security/pam_krb5/pkg-plist
@@ -1,2 +1,2 @@
lib/pam_krb5.so
-lib/pam_krb5.so.1
+lib/pam_krb5.la