summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-09-26 20:36:57 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-09-26 20:36:57 +0000
commitc3bd512bf767b6094dc504b2ef0bfcb735efb73d (patch)
treecb184fb5c9301d2ab92831ce73f972f7022be4ff
parent- Update to 2.0.2 (diff)
- Update to 0.9.0
Cherokee: - Adds a MySQL bridge and load balancer - Adds TLS SNI support - Adds support for expiration headers - Adds a custom error handler - Adds encoding fine grain management - Chunked Encoding support is much faster now - TLS/SSL support bugfixes - Keep-Alive bugfixes - Uses a new 'information source' concept - Adds relative path support to -r Documentation: - Huge documentation update - Man pages updates Administration interface: - It implements form auto-submission - In certain cases, it hides useless options - Its help support has been dastrically improved
-rw-r--r--www/cherokee/Makefile9
-rw-r--r--www/cherokee/distinfo6
-rw-r--r--www/cherokee/pkg-plist40
3 files changed, 30 insertions, 25 deletions
diff --git a/www/cherokee/Makefile b/www/cherokee/Makefile
index 93ce508cdefa..37171f620b05 100644
--- a/www/cherokee/Makefile
+++ b/www/cherokee/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= cherokee
-PORTVERSION= 0.8.1
-PORTREVISION= 2
+PORTVERSION= 0.9.0
CATEGORIES= www
-MASTER_SITES= http://www.cherokee-project.com/download/0.8/${PORTVERSION}/ \
+MASTER_SITES= http://www.cherokee-project.com/download/0.9/${PORTVERSION}/ \
LOCAL/beech
MAINTAINER= beech@FreeBSD.org
@@ -18,7 +17,7 @@ COMMENT= Extremely fast and flexible web server
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre \
GeoIP.5:${PORTSDIR}/net/GeoIP
-CONFLICTS= cherokee-[0-9]*
+CONFLICTS= cherokee-devel-[0-9]*
USE_GNOME= gnomehack gnometarget pkgconfig
USE_LDCONFIG= yes
USE_RC_SUBR= cherokee.sh
@@ -37,7 +36,7 @@ CONFIGURE_ARGS= --with-wwwroot=${PREFIX}/www/cherokee \
DEFCONFS= cherokee.conf
CONFSUBDIRS= ssl mods-available mods-enabled sites-available sites-enabled
MAN1= cget.1 cherokee-config.1 cherokee.1 cherokee-admin.1 \
- spawn-fcgi.1 cherokee-tweak.1 cherokee-guardian.1
+ spawn-fcgi.1 cherokee-tweak.1 cherokee-worker.1
PORTDOCS= *
OPTIONS= OPENSSL "TLS/SSL support via openssl" on \
diff --git a/www/cherokee/distinfo b/www/cherokee/distinfo
index 9b921fdac5f4..17f13152c375 100644
--- a/www/cherokee/distinfo
+++ b/www/cherokee/distinfo
@@ -1,3 +1,3 @@
-MD5 (cherokee-0.8.1.tar.gz) = c082d4660f068c4f43f821ae8a0c7157
-SHA256 (cherokee-0.8.1.tar.gz) = d159eae221221492bfc4d6139926480d713d84c50a00807e0725f7af2e1d6c9f
-SIZE (cherokee-0.8.1.tar.gz) = 3052809
+MD5 (cherokee-0.9.0.tar.gz) = 9094a748752573cb3be380ed2d28092c
+SHA256 (cherokee-0.9.0.tar.gz) = d266e2adf77d9b9e0d72f63695da1d03dfd86f38830bbb8d4a8482df2f89ef41
+SIZE (cherokee-0.9.0.tar.gz) = 3024326
diff --git a/www/cherokee/pkg-plist b/www/cherokee/pkg-plist
index 736e40339b5b..8810aef6fde9 100644
--- a/www/cherokee/pkg-plist
+++ b/www/cherokee/pkg-plist
@@ -15,6 +15,7 @@ include/cherokee/admin_client.h
include/cherokee/avl.h
include/cherokee/avl_r.h
include/cherokee/buffer.h
+include/cherokee/cache.h
include/cherokee/cherokee-config.h
include/cherokee/cherokee.h
include/cherokee/common.h
@@ -57,6 +58,10 @@ lib/cherokee/libplugin_combined.la
lib/cherokee/libplugin_combined.so
lib/cherokee/libplugin_common.la
lib/cherokee/libplugin_common.so
+lib/cherokee/libplugin_custom_error.la
+lib/cherokee/libplugin_custom_error.so
+lib/cherokee/libplugin_dbslayer.la
+lib/cherokee/libplugin_dbslayer.so
lib/cherokee/libplugin_deflate.la
lib/cherokee/libplugin_deflate.so
lib/cherokee/libplugin_directory.la
@@ -132,7 +137,7 @@ lib/libcherokee-server.so.0
libdata/pkgconfig/cherokee.pc
sbin/cherokee
sbin/cherokee-admin
-sbin/cherokee-guardian
+sbin/cherokee-worker
share/aclocal/cherokee.m4
%%DATADIR%%/admin/CherokeeManagement.py
%%DATADIR%%/admin/CherokeeManagement.pyc
@@ -152,6 +157,10 @@ share/aclocal/cherokee.m4
%%DATADIR%%/admin/ModuleCgi.pyc
%%DATADIR%%/admin/ModuleCommon.py
%%DATADIR%%/admin/ModuleCommon.pyc
+%%DATADIR%%/admin/ModuleCustomError.py
+%%DATADIR%%/admin/ModuleCustomError.pyc
+%%DATADIR%%/admin/ModuleDbslayer.py
+%%DATADIR%%/admin/ModuleDbslayer.pyc
%%DATADIR%%/admin/ModuleDefault.py
%%DATADIR%%/admin/ModuleDefault.pyc
%%DATADIR%%/admin/ModuleDirectory.py
@@ -170,6 +179,10 @@ share/aclocal/cherokee.m4
%%DATADIR%%/admin/ModuleFile.pyc
%%DATADIR%%/admin/ModuleGeoip.py
%%DATADIR%%/admin/ModuleGeoip.pyc
+%%DATADIR%%/admin/ModuleHandler.py
+%%DATADIR%%/admin/ModuleHandler.pyc
+%%DATADIR%%/admin/ModuleHeader.py
+%%DATADIR%%/admin/ModuleHeader.pyc
%%DATADIR%%/admin/ModuleHtdigest.py
%%DATADIR%%/admin/ModuleHtdigest.pyc
%%DATADIR%%/admin/ModuleHtpasswd.py
@@ -200,8 +213,6 @@ share/aclocal/cherokee.m4
%%DATADIR%%/admin/PageAdvanced.pyc
%%DATADIR%%/admin/PageAjaxUpdate.py
%%DATADIR%%/admin/PageAjaxUpdate.pyc
-%%DATADIR%%/admin/PageEncoders.py
-%%DATADIR%%/admin/PageEncoders.pyc
%%DATADIR%%/admin/PageEntry.py
%%DATADIR%%/admin/PageEntry.pyc
%%DATADIR%%/admin/PageError.py
@@ -212,10 +223,12 @@ share/aclocal/cherokee.m4
%%DATADIR%%/admin/PageGeneral.pyc
%%DATADIR%%/admin/PageIcon.py
%%DATADIR%%/admin/PageIcon.pyc
-%%DATADIR%%/admin/PageMain.py
-%%DATADIR%%/admin/PageMain.pyc
+%%DATADIR%%/admin/PageInfoSource.py
+%%DATADIR%%/admin/PageInfoSource.pyc
%%DATADIR%%/admin/PageMime.py
%%DATADIR%%/admin/PageMime.pyc
+%%DATADIR%%/admin/PageStatus.py
+%%DATADIR%%/admin/PageStatus.pyc
%%DATADIR%%/admin/PageVServer.py
%%DATADIR%%/admin/PageVServer.pyc
%%DATADIR%%/admin/PageVServers.py
@@ -228,7 +241,6 @@ share/aclocal/cherokee.m4
%%DATADIR%%/admin/Table.pyc
%%DATADIR%%/admin/Theme.py
%%DATADIR%%/admin/Theme.pyc
-%%DATADIR%%/admin/advanced.help.html
%%DATADIR%%/admin/config.py
%%DATADIR%%/admin/config.pyc
%%DATADIR%%/admin/configured.py
@@ -236,26 +248,19 @@ share/aclocal/cherokee.m4
%%DATADIR%%/admin/consts.py
%%DATADIR%%/admin/consts.pyc
%%DATADIR%%/admin/default.template.html
-%%DATADIR%%/admin/encoder.help.html
-%%DATADIR%%/admin/entry.help.html
%%DATADIR%%/admin/error_couldnt_launch.template.html
%%DATADIR%%/admin/error_icons_dir_missing.template.html
%%DATADIR%%/admin/error_not_found.template.html
%%DATADIR%%/admin/error_not_writable.template.html
-%%DATADIR%%/admin/feedback.help.html
%%DATADIR%%/admin/flags.py
%%DATADIR%%/admin/flags.pyc
-%%DATADIR%%/admin/general.help.html
-%%DATADIR%%/admin/icon.help.html
-%%DATADIR%%/admin/main.help.html
-%%DATADIR%%/admin/main.template.html
-%%DATADIR%%/admin/mime.help.html
%%DATADIR%%/admin/pyscgi.py
%%DATADIR%%/admin/pyscgi.pyc
%%DATADIR%%/admin/server.py
%%DATADIR%%/admin/server.pyc
%%DATADIR%%/admin/static/css/cherokee.css
%%DATADIR%%/admin/static/css/reset-min.css
+%%DATADIR%%/admin/static/css/thickbox.css
%%DATADIR%%/admin/static/images/background.png
%%DATADIR%%/admin/static/images/bin.png
%%DATADIR%%/admin/static/images/button-left.png
@@ -514,6 +519,8 @@ share/aclocal/cherokee.m4
%%DATADIR%%/admin/static/images/flags/zm.png
%%DATADIR%%/admin/static/images/flags/zw.png
%%DATADIR%%/admin/static/images/help.png
+%%DATADIR%%/admin/static/images/loadingAnimation.gif
+%%DATADIR%%/admin/static/images/macFFBgHack.png
%%DATADIR%%/admin/static/images/menu-active.png
%%DATADIR%%/admin/static/images/menu-highlight.png
%%DATADIR%%/admin/static/images/offline.png
@@ -526,11 +533,10 @@ share/aclocal/cherokee.m4
%%DATADIR%%/admin/static/js/jquery.dimensions.js
%%DATADIR%%/admin/static/js/jquery.easing.js
%%DATADIR%%/admin/static/js/jquery.tablednd.js
+%%DATADIR%%/admin/static/js/thickbox.js
+%%DATADIR%%/admin/status.template.html
%%DATADIR%%/admin/validations.py
%%DATADIR%%/admin/validations.pyc
-%%DATADIR%%/admin/vserver.help.html
-%%DATADIR%%/admin/vservers.help.html
-
%%DATADIR%%/deps/cgi.deps
%%DATADIR%%/deps/combined.deps
%%DATADIR%%/deps/common.deps