summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2004-12-08 15:31:32 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2004-12-08 15:31:32 +0000
commitbc343a7df3c7a84ada3c1595b8ca0c8ee5337bc4 (patch)
tree183ef5bb22b54f4eecc6fc9123378645fe23da82
parentMark BROKEN since it "does not work with python 2.4" (diff)
PyQt doesn't like python 2.4, restrict it and ports depending on it to
python 2.3 for the time being.
-rw-r--r--deskutils/treeline/Makefile2
-rw-r--r--devel/kodos/Makefile2
-rw-r--r--devel/py-sip/Makefile2
-rw-r--r--graphics/imgseek/Makefile2
-rw-r--r--graphics/lphoto/Makefile2
-rw-r--r--math/convertall/Makefile2
-rw-r--r--misc/flyway/Makefile2
-rw-r--r--net-p2p/qtorrent/Makefile2
-rw-r--r--net/qtorrent/Makefile2
-rw-r--r--sysutils/luma/Makefile2
-rw-r--r--x11-toolkits/py-kde/Makefile2
-rw-r--r--x11-toolkits/py-qt/Makefile2
12 files changed, 12 insertions, 12 deletions
diff --git a/deskutils/treeline/Makefile b/deskutils/treeline/Makefile
index 7a653002f836..0c53765540e7 100644
--- a/deskutils/treeline/Makefile
+++ b/deskutils/treeline/Makefile
@@ -33,7 +33,7 @@ LIB_DEPENDS+= expat.5:${PORTSDIR}/textproc/expat2
WRKSRC= ${WRKDIR}/TreeLine
USE_QT_VER= 3
-USE_PYTHON= 2.3+
+USE_PYTHON= 2.3
NO_BUILD= yes
pre-everything::
diff --git a/devel/kodos/Makefile b/devel/kodos/Makefile
index 7d59bd660fdb..b8a76f0c1e82 100644
--- a/devel/kodos/Makefile
+++ b/devel/kodos/Makefile
@@ -19,7 +19,7 @@ COMMENT= The Python Regular Expression Debugger
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/qt.so:${PORTSDIR}/x11-toolkits/py-qt
USE_REINPLACE= yes
-USE_PYTHON= 1.5+
+USE_PYTHON= 1.5-2.3
USE_PYDISTUTILS= yes
PLIST_FILES= bin/kodos ${PYTHON_SITELIBDIR:S,^${PREFIX}/,,}/kodos.pth
diff --git a/devel/py-sip/Makefile b/devel/py-sip/Makefile
index 7604ec983668..9e161b0ca7c7 100644
--- a/devel/py-sip/Makefile
+++ b/devel/py-sip/Makefile
@@ -15,7 +15,7 @@ COMMENT= Python to C and C++ bindings generator
BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
-USE_PYTHON= yes
+USE_PYTHON= 2.3
USE_QT_VER= 3
.include <bsd.port.pre.mk>
diff --git a/graphics/imgseek/Makefile b/graphics/imgseek/Makefile
index cd0d45f33e6c..e8111eb2eb67 100644
--- a/graphics/imgseek/Makefile
+++ b/graphics/imgseek/Makefile
@@ -20,7 +20,7 @@ BUILD_DEPENDS= pyuic:${PORTSDIR}/x11-toolkits/py-qt \
USE_CONFIGURE= no
USE_PYDISTUTILS= yes
-USE_PYTHON= yes
+USE_PYTHON= 2.3
USE_BZIP2= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= ${PYTHON_SITELIBDIR}/imgSeekLib
diff --git a/graphics/lphoto/Makefile b/graphics/lphoto/Makefile
index d4e47f3a9d47..be255e0f7d1b 100644
--- a/graphics/lphoto/Makefile
+++ b/graphics/lphoto/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= gphoto2:${PORTSDIR}/graphics/gphoto2 \
kdepyuic:${PORTSDIR}/x11-toolkits/py-kde
USE_REINPLACE= yes
-USE_PYTHON= yes
+USE_PYTHON= 2.3
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/math/convertall/Makefile b/math/convertall/Makefile
index b1e8da8cc280..d83572b1747d 100644
--- a/math/convertall/Makefile
+++ b/math/convertall/Makefile
@@ -18,7 +18,7 @@ RUN_DEPENDS= pyuic:${PORTSDIR}/x11-toolkits/py-qt
WRKSRC= ${WRKDIR}/ConvertAll
USE_REINPLACE= yes
-USE_PYTHON= yes
+USE_PYTHON= 2.3
USE_X_PREFIX= yes
NO_BUILD= yes
PORTDOCS= README.html INSTALL LICENSE
diff --git a/misc/flyway/Makefile b/misc/flyway/Makefile
index 0f128a187e0c..0b75b0c3820d 100644
--- a/misc/flyway/Makefile
+++ b/misc/flyway/Makefile
@@ -18,7 +18,7 @@ BUILD_DEPENDS= pyuic:${PORTSDIR}/x11-toolkits/py-qt
RUN_DEPENDS= pyuic:${PORTSDIR}/x11-toolkits/py-qt
USE_X_PREFIX= yes
-USE_PYTHON= yes
+USE_PYTHON= 2.3
USE_REINPLACE= yes
NO_BUILD= yes
WRKSRC= ${WRKDIR}/FlyWay
diff --git a/net-p2p/qtorrent/Makefile b/net-p2p/qtorrent/Makefile
index 6d846b67d8d3..204de6018226 100644
--- a/net-p2p/qtorrent/Makefile
+++ b/net-p2p/qtorrent/Makefile
@@ -17,7 +17,7 @@ BUILD_DEPENDS= pyuic:${PORTSDIR}/x11-toolkits/py-qt
RUN_DEPENDS= pyuic:${PORTSDIR}/x11-toolkits/py-qt
USE_BZIP2= yes
-USE_PYTHON= yes
+USE_PYTHON= 2.3
USE_PYDISTUTILS=yes
pre-everything::
diff --git a/net/qtorrent/Makefile b/net/qtorrent/Makefile
index 6d846b67d8d3..204de6018226 100644
--- a/net/qtorrent/Makefile
+++ b/net/qtorrent/Makefile
@@ -17,7 +17,7 @@ BUILD_DEPENDS= pyuic:${PORTSDIR}/x11-toolkits/py-qt
RUN_DEPENDS= pyuic:${PORTSDIR}/x11-toolkits/py-qt
USE_BZIP2= yes
-USE_PYTHON= yes
+USE_PYTHON= 2.3
USE_PYDISTUTILS=yes
pre-everything::
diff --git a/sysutils/luma/Makefile b/sysutils/luma/Makefile
index 65c12c9e7abc..7abe46773308 100644
--- a/sysutils/luma/Makefile
+++ b/sysutils/luma/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_ldap.so:${PORTSDIR}/net/py-ldap2 \
pyuic:${PORTSDIR}/x11-toolkits/py-qt
USE_BZIP2= yes
-USE_PYTHON= yes
+USE_PYTHON= 2.3
USE_PYDISTUTILS= yes
PYSETUP= install.py
PYDISTUTILS_BUILDARGS= build
diff --git a/x11-toolkits/py-kde/Makefile b/x11-toolkits/py-kde/Makefile
index b562293c6951..f88ca61f706f 100644
--- a/x11-toolkits/py-kde/Makefile
+++ b/x11-toolkits/py-kde/Makefile
@@ -21,7 +21,7 @@ BROKEN= "Does not compile with KDE >= 3.3.1"
BUILD_DEPENDS= pyuic:${PORTSDIR}/x11-toolkits/py-qt
RUN_DEPENDS= ${BUILD_DEPENDS}
-USE_PYTHON= yes
+USE_PYTHON= 2.3
USE_KDELIBS_VER=3
USE_REINPLACE= yes
diff --git a/x11-toolkits/py-qt/Makefile b/x11-toolkits/py-qt/Makefile
index b8d412320286..68dcd7713dc8 100644
--- a/x11-toolkits/py-qt/Makefile
+++ b/x11-toolkits/py-qt/Makefile
@@ -19,7 +19,7 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/sip:${PORTSDIR}/devel/py-sip
RUN_DEPENDS= ${BUILD_DEPENDS}
USE_QT_VER= 3
-USE_PYTHON= yes
+USE_PYTHON= 2.3
USE_REINPLACE= yes
.include <bsd.port.pre.mk>