summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-09-12 21:11:30 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-09-12 21:11:30 +0000
commitbb7c6094dcdc2e784d08d5c71a3d35e56d4af6fc (patch)
treee39fee500dd1304bb248b956ce732445ffb6cba6
parentFix plist. (diff)
This module allows you to extract Hatena keywords used in an
arbitrary text and also allows you to mark up a text as HTML with the keywords. A Hatena keyword is an element in a suite of web sites *.hatena.ne.jp having blogs and social bookmarks among others. Please refer to http://d.hatena.ne.jp/keyword/ (in Japanese) for details. In Hatena Diary, a blog hosting service, a Hatena keyword found in a posting is linked to the keywords page automatically. You can implement the same kind of feature outside Hatena using this module. It queries Hatena Keyword Link API internally for retrieving terms Author: Naoya Ito <naoya@bloghackers.net> WWW: http://search.cpan.org/~naoya/Hatena-Keyword-0.04/ PR: ports/102794 Submitted by: Masahiro Teramoto <markun(at)onohara.to>
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Hatena-Keyword/Makefile30
-rw-r--r--textproc/p5-Hatena-Keyword/distinfo3
-rw-r--r--textproc/p5-Hatena-Keyword/pkg-descr16
-rw-r--r--textproc/p5-Hatena-Keyword/pkg-plist7
5 files changed, 57 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 7323ecb3d388..de500b05d895 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -342,6 +342,7 @@
SUBDIR += p5-HTML-Tidy
SUBDIR += p5-HTML-Truncate
SUBDIR += p5-Hash-Merge
+ SUBDIR += p5-Hatena-Keyword
SUBDIR += p5-IDNA-Punycode
SUBDIR += p5-IO-CSVHeaderFile
SUBDIR += p5-KinoSearch
diff --git a/textproc/p5-Hatena-Keyword/Makefile b/textproc/p5-Hatena-Keyword/Makefile
new file mode 100644
index 000000000000..e24a549cd0c7
--- /dev/null
+++ b/textproc/p5-Hatena-Keyword/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-Hatena-Keyword
+# Date created: 2006-09-02
+# Whom: Masahiro Teramoto <markun@onohara.to>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Hatena-Keyword
+PORTVERSION= 0.04
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/N/NA/NAOYA
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= markun@onohara.to
+COMMENT= Extract Hatena Keywords in a string
+
+BUILD_DEPENDS= ${SITE_PERL}/RPC/XML.pm:${PORTSDIR}/net/p5-RPC-XML \
+ ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${SITE_PERL}/Class/Data/Inheritable.pm:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
+ ${SITE_PERL}/Class/ErrorHandler.pm:${PORTSDIR}/devel/p5-Class-ErrorHandler \
+ ${SITE_PERL}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Hatena::Keyword.3
+
+.include <bsd.port.pre.mk>
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-Hatena-Keyword/distinfo b/textproc/p5-Hatena-Keyword/distinfo
new file mode 100644
index 000000000000..9def47b1c3fb
--- /dev/null
+++ b/textproc/p5-Hatena-Keyword/distinfo
@@ -0,0 +1,3 @@
+MD5 (Hatena-Keyword-0.04.tar.gz) = a0bc79dd29f98b2b644d8d47e19ce88b
+SHA256 (Hatena-Keyword-0.04.tar.gz) = 3c315a32bc5dfd5db016d1b62f2ced75e7673f3ea3673dfca10564c6b55f72bd
+SIZE (Hatena-Keyword-0.04.tar.gz) = 6138
diff --git a/textproc/p5-Hatena-Keyword/pkg-descr b/textproc/p5-Hatena-Keyword/pkg-descr
new file mode 100644
index 000000000000..5158ef4ba6f6
--- /dev/null
+++ b/textproc/p5-Hatena-Keyword/pkg-descr
@@ -0,0 +1,16 @@
+This module allows you to extract Hatena keywords used in an
+arbitrary text and also allows you to mark up a text as HTML
+with the keywords.
+
+A Hatena keyword is an element in a suite of web sites
+*.hatena.ne.jp having blogs and social bookmarks among others.
+Please refer to http://d.hatena.ne.jp/keyword/ (in Japanese) for details.
+
+In Hatena Diary, a blog hosting service, a Hatena keyword found in
+a posting is linked to the keywords page automatically.
+You can implement the same kind of feature outside Hatena using this module.
+
+It queries Hatena Keyword Link API internally for retrieving terms
+
+Author: Naoya Ito <naoya@bloghackers.net>
+WWW: http://search.cpan.org/~naoya/Hatena-Keyword-0.04/
diff --git a/textproc/p5-Hatena-Keyword/pkg-plist b/textproc/p5-Hatena-Keyword/pkg-plist
new file mode 100644
index 000000000000..a0f1d1da0941
--- /dev/null
+++ b/textproc/p5-Hatena-Keyword/pkg-plist
@@ -0,0 +1,7 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Hatena/Keyword/.packlist
+%%SITE_PERL%%/Hatena/Keyword.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Hatena/Keyword
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Hatena
+@dirrmtry %%SITE_PERL%%/Hatena/Keyword
+@dirrmtry %%SITE_PERL%%/Hatena