summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian S. Dean <bsd@FreeBSD.org>2003-04-14 00:46:49 +0000
committerBrian S. Dean <bsd@FreeBSD.org>2003-04-14 00:46:49 +0000
commitb69837de0f9423b9d0f293566089588451327e9c (patch)
tree97bf303cdc5e5f9503986971b04e8a7c5609fcfd
parentAdd meld, a GNOME 2 visual diff utility written in Python. (diff)
Add AVaRICE - a program for providing a debugging layer so that GNU
GDB can be used to debug Atmel AVR programs in-system on JTAG enabled devices, to be used in combination with the Atmel JTAG ICE hardware. This program can also be used for programming the device as well as debugging the code.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/avarice/Makefile23
-rw-r--r--devel/avarice/distinfo1
-rw-r--r--devel/avarice/pkg-descr8
-rw-r--r--devel/avarice/pkg-plist7
5 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b340fc2727dc..866ff826cecd 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -54,6 +54,7 @@
SUBDIR += automake
SUBDIR += automake14
SUBDIR += automake17
+ SUBDIR += avarice
SUBDIR += avltree
SUBDIR += avr-binutils
SUBDIR += avr-gcc
diff --git a/devel/avarice/Makefile b/devel/avarice/Makefile
new file mode 100644
index 000000000000..427a3ec9fa90
--- /dev/null
+++ b/devel/avarice/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: avarice
+# Date created: 13 April 2003
+# Whom: Brian Dean <bsd@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= avarice
+PORTVERSION= 2.0.20030403
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= bsd
+DISTNAME= ${PORTNAME}-${PORTVERSION}cvs
+
+MAINTAINER= bsd@FreeBSD.org
+COMMENT= Atmel AVR JTAG programmer and debugging interface for avr-gdb
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}cvs
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX}
+
+.include <bsd.port.mk>
diff --git a/devel/avarice/distinfo b/devel/avarice/distinfo
new file mode 100644
index 000000000000..870cc003057e
--- /dev/null
+++ b/devel/avarice/distinfo
@@ -0,0 +1 @@
+MD5 (avarice-2.0.20030403cvs.tar.gz) = f78ffb4ef41abdecb2375ec9515e41d8
diff --git a/devel/avarice/pkg-descr b/devel/avarice/pkg-descr
new file mode 100644
index 000000000000..e1126a393b7d
--- /dev/null
+++ b/devel/avarice/pkg-descr
@@ -0,0 +1,8 @@
+AVaRICE is a program which interfaces the GNU Debugger GDB with the
+AVR JTAG ICE available from Atmel.
+
+Use AVaRICE standalone as a programmer, or it can be run as an
+intermediary between avr-gdb and the AVR JTAG hardware, allowing one
+to use GDB to debug your AVR code as it runs in-system.
+
+WWW: http://avarice.sourceforge.net/
diff --git a/devel/avarice/pkg-plist b/devel/avarice/pkg-plist
new file mode 100644
index 000000000000..5af6a3332e82
--- /dev/null
+++ b/devel/avarice/pkg-plist
@@ -0,0 +1,7 @@
+bin/avarice
+bin/start-avarice
+bin/kill-avarice
+bin/ice-gdb
+bin/ice-insight
+share/avarice/gdb-avarice-script
+@dirrm share/avarice