summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBill Fumerola <billf@FreeBSD.org>1999-02-22 01:34:12 +0000
committerBill Fumerola <billf@FreeBSD.org>1999-02-22 01:34:12 +0000
commit8580b6cf502dec6cadf7b6aa507bfc4efe571759 (patch)
tree41fc563c8ce6df43f9b245a83c14f357f5f1b125
parentUpgrade to 1.6.10 (diff)
A Perl script that makes use of TCP/IP as underlying protocol to fetch
headlines and financial news. Use it to keep track of Linux headlines, monitor your interests in foreign currency and monitor your portafolio of company stocks. All of this from a simple command line interface. http://www.iae.nl/users/grimaldo/OpenSoft/quotes.shtml PR: ports/9981 Submitted By: Dima Sivachenko <dima@Chg.RU>
-rw-r--r--misc/quotes/Makefile41
-rw-r--r--misc/quotes/distinfo1
-rw-r--r--misc/quotes/pkg-comment1
-rw-r--r--misc/quotes/pkg-descr9
-rw-r--r--misc/quotes/pkg-plist5
5 files changed, 57 insertions, 0 deletions
diff --git a/misc/quotes/Makefile b/misc/quotes/Makefile
new file mode 100644
index 000000000000..96ea4663ba0d
--- /dev/null
+++ b/misc/quotes/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: quotes
+# Version required: 1.3.0
+# Date created: 9 February 1999
+# Whom: Dima Sivachenko
+#
+# $Id: $
+#
+
+DISTNAME= quotes-1.3-0
+PKGNAME= quotes-1.3.0
+CATEGORIES= misc
+MASTER_SITES= ftp://ftp.iae.nl/pub/users/grimaldo/ \
+ http://www.FreeBSD.org/~billf/distfiles/
+
+MAINTAINER= dima@Chg.RU
+
+WRKSRC= ${WRKDIR}/Quotes-1.3-0
+
+NO_BUILD= yes
+USE_PERL5= yes
+
+post-patch:
+
+ @ ${MV} ${WRKSRC}/quotes ${WRKSRC}/quotes.pre_sed
+ @ ${SED} -e 's#/usr/bin/perl#${PERL5}#' ${WRKSRC}/quotes.pre_sed \
+ > ${WRKSRC}/quotes
+ @ ${MV} ${WRKSRC}/QuExample.pm ${WRKSRC}/QuExample.pm.pre_sed
+ @ ${SED} -e 's#/usr/bin/perl#${PERL5}#' ${WRKSRC}/QuExample.pm.pre_sed \
+ > ${WRKSRC}/QuExample.pm
+
+do-install:
+
+ @ ${INSTALL_SCRIPT} ${WRKSRC}/quotes ${PREFIX}/bin
+ @ ${INSTALL_DATA} ${WRKSRC}/sample.quotesrc ${PREFIX}/etc
+.if !defined(NOPORTDOCS)
+ @ ${MKDIR} ${PREFIX}/share/doc/quotes
+ @ ${INSTALL_DATA} ${WRKSRC}/quotes.txt ${PREFIX}/share/doc/quotes
+ @ ${INSTALL_DATA} ${WRKSRC}/QuExample.pm ${PREFIX}/share/doc/quotes
+.endif
+
+.include <bsd.port.mk>
diff --git a/misc/quotes/distinfo b/misc/quotes/distinfo
new file mode 100644
index 000000000000..17e1b404dad6
--- /dev/null
+++ b/misc/quotes/distinfo
@@ -0,0 +1 @@
+MD5 (quotes-1.3-0.tar.gz) = 2a817d162f40ee5c74cd82c720920de5
diff --git a/misc/quotes/pkg-comment b/misc/quotes/pkg-comment
new file mode 100644
index 000000000000..93a7dac9c520
--- /dev/null
+++ b/misc/quotes/pkg-comment
@@ -0,0 +1 @@
+Script to fetch headlines and financial news.
diff --git a/misc/quotes/pkg-descr b/misc/quotes/pkg-descr
new file mode 100644
index 000000000000..ff89e6832e0a
--- /dev/null
+++ b/misc/quotes/pkg-descr
@@ -0,0 +1,9 @@
+It is a Perl script that makes use of TCP/IP as underlying protocol to fetch
+headlines and financial news. Use it to keep track of Linux headlines,
+monitor your interests in foreign currency and monitor your portafolio of
+company stocks. All of this from a simple command line interface.
+
+http://www.iae.nl/users/grimaldo/OpenSoft/quotes.shtml
+
+--Dima
+dima@chg.ru
diff --git a/misc/quotes/pkg-plist b/misc/quotes/pkg-plist
new file mode 100644
index 000000000000..82d3df915428
--- /dev/null
+++ b/misc/quotes/pkg-plist
@@ -0,0 +1,5 @@
+bin/quotes
+etc/sample.quotesrc
+share/doc/quotes/quotes.txt
+share/doc/quotes/QuExample.pm
+@dirrm share/doc/quotes