summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-04-20 12:13:04 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-04-20 12:13:04 +0000
commit73ed726252e81ca5fcf9245c26b27068ad55f72a (patch)
treed14a1443fd5424c53abb3e44b1021c39d3aa1927
parentAdd p5-Text-ASCIITable 0.15, create a nice formatted table using ASCII (diff)
- Update to 0.4.13
PR: ports/80057 Submitted by: Li-Lun Wang (Leland Wang) <llwang@infor.org> (maintainer)
-rw-r--r--graphics/libflash/Makefile6
-rw-r--r--graphics/libflash/distinfo4
-rw-r--r--graphics/libflash/files/patch-lib::Makefile.in7
-rw-r--r--www/flashplugin-mozilla/Makefile7
-rw-r--r--www/flashplugin-mozilla/distinfo4
-rw-r--r--www/flashplugin-mozilla/files/patch-plugin.c50
6 files changed, 45 insertions, 33 deletions
diff --git a/graphics/libflash/Makefile b/graphics/libflash/Makefile
index 7db2e461a705..f0c3348f1249 100644
--- a/graphics/libflash/Makefile
+++ b/graphics/libflash/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libflash
-PORTVERSION= 0.4.12
+PORTVERSION= 0.4.13
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= gplflash
@@ -27,5 +27,9 @@ CONFIGURE_WRKSRC= ${WRKDIR}/${DISTNAME}
USE_BZIP2= yes
USE_XLIB= yes
INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|stdint.h|inttypes.h|' ${WRKSRC}/swf.h
.include <bsd.port.mk>
diff --git a/graphics/libflash/distinfo b/graphics/libflash/distinfo
index 9343a34ff8a0..126c90c44cf1 100644
--- a/graphics/libflash/distinfo
+++ b/graphics/libflash/distinfo
@@ -1,2 +1,2 @@
-MD5 (gplflash-0.4.12.tar.bz2) = 7d53803486b255665a80cd834ee3c463
-SIZE (gplflash-0.4.12.tar.bz2) = 378727
+MD5 (gplflash-0.4.13.tar.bz2) = 1b14c21094eb07416842ac0f5298b3f1
+SIZE (gplflash-0.4.13.tar.bz2) = 323128
diff --git a/graphics/libflash/files/patch-lib::Makefile.in b/graphics/libflash/files/patch-lib::Makefile.in
index 1f77e520cd00..691ac1beae1b 100644
--- a/graphics/libflash/files/patch-lib::Makefile.in
+++ b/graphics/libflash/files/patch-lib::Makefile.in
@@ -1,11 +1,10 @@
---- lib/Makefile.in.orig Fri Oct 15 13:34:57 2004
-+++ lib/Makefile.in Wed Nov 17 16:03:58 2004
-@@ -256,8 +256,7 @@
+--- lib/Makefile.in.orig Wed Jan 19 12:30:52 2005
++++ lib/Makefile.in Mon Apr 18 04:59:51 2005
+@@ -256,7 +256,7 @@
libflash_includedir = $(includedir)
libflash_la_LDFLAGS = \
- -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
-- -release $(LT_RELEASE) \
+ -version-info $(LT_CURRENT) \
-export-dynamic \
$(LIBJPEG) $(LIBZ) $(LIBMAD)
diff --git a/www/flashplugin-mozilla/Makefile b/www/flashplugin-mozilla/Makefile
index e936ad629e21..2aee5a1a739a 100644
--- a/www/flashplugin-mozilla/Makefile
+++ b/www/flashplugin-mozilla/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME?= flashplugin-mozilla
-PORTVERSION= 0.4.12
-PORTREVISION= 1
+PORTVERSION= 0.4.13
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= gplflash
@@ -17,14 +16,13 @@ MAINTAINER= llwang@infor.org
COMMENT= A GPL standalone Flash (TM) plugin for Mozilla web browser
LIB_DEPENDS= flash.0:${PORTSDIR}/graphics/libflash
-RUN_DEPENDS?= mozilla:${PORTSDIR}/www/mozilla
WRKSRC= ${WRKDIR}/${DISTNAME}/plugin
USE_BZIP2= yes
USE_REINPLACE= yes
USE_X_PREFIX= yes
-PLUGIN_DIR?= lib/browser_plugins
+PLUGIN_DIR= lib/browser_plugins
PLIST_SUB+= PLUGIN_DIR=${PLUGIN_DIR}
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-plugin-dir="${PREFIX}/${PLUGIN_DIR}"
@@ -36,5 +34,6 @@ post-patch:
@${REINPLACE_CMD} -e "s,-L../lib/.libs,-L${LOCALBASE}/lib," \
-e "s/libnpflash.so.0.0.0/libnpflash.so.0/" \
${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|stdint.h|inttypes.h|' ${WRKSRC}/npapi.h
.include <bsd.port.mk>
diff --git a/www/flashplugin-mozilla/distinfo b/www/flashplugin-mozilla/distinfo
index 9343a34ff8a0..126c90c44cf1 100644
--- a/www/flashplugin-mozilla/distinfo
+++ b/www/flashplugin-mozilla/distinfo
@@ -1,2 +1,2 @@
-MD5 (gplflash-0.4.12.tar.bz2) = 7d53803486b255665a80cd834ee3c463
-SIZE (gplflash-0.4.12.tar.bz2) = 378727
+MD5 (gplflash-0.4.13.tar.bz2) = 1b14c21094eb07416842ac0f5298b3f1
+SIZE (gplflash-0.4.13.tar.bz2) = 323128
diff --git a/www/flashplugin-mozilla/files/patch-plugin.c b/www/flashplugin-mozilla/files/patch-plugin.c
index a77f089cc89e..13150f221205 100644
--- a/www/flashplugin-mozilla/files/patch-plugin.c
+++ b/www/flashplugin-mozilla/files/patch-plugin.c
@@ -1,20 +1,30 @@
-*** plugin.c.old Mon Jun 12 10:24:09 2000
---- plugin.c Mon Sep 30 00:48:40 2002
-***************
-*** 193,198 ****
---- 193,207 ----
- XSync(This->dpy,False);
- XFreePixmap(This->dpy, This->canvas);
- shmdt(This->segInfo.shmaddr);
-+ #ifndef linux
-+ {
-+ struct shmid_ds buf;
-+
-+ if (shmctl(This->segInfo.shmid, IPC_RMID, &buf) < 0) {
-+ perror("shmctl");
-+ }
-+ }
-+ #endif
-
- FlashClose(This->fh);
- This->fh = 0;
+--- plugin.c.orig Wed Jan 19 19:30:52 2005
++++ plugin.c Wed Apr 20 14:10:14 2005
+@@ -194,6 +194,15 @@
+ XSync(This->dpy,False);
+ XFreePixmap(This->dpy, This->canvas);
+ shmdt(This->segInfo.shmaddr);
++#ifndef linux
++ {
++ struct shmid_ds buf;
++
++ if (shmctl(This->segInfo.shmid, IPC_RMID, &buf) < 0) {
++ perror("shmctl");
++ }
++ }
++#endif
+
+ FlashClose(This->fh);
+ This->fh = 0;
+@@ -257,10 +266,10 @@
+ static void
+ flashWakeUp(XtPointer client_data, XtIntervalId *id)
+ {
+- pthread_mutex_lock(&synchro);
+ PluginInstance* This;
+ long cmd;
+ long wakeUp;
++ pthread_mutex_lock(&synchro);
+
+ This = (PluginInstance*)client_data;
+