summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-07-31 12:16:59 +0000
committerClement Laforet <clement@FreeBSD.org>2004-07-31 12:16:59 +0000
commit6ce2dae5a7c1906b92368ccaea4d3ff42bd8d4e7 (patch)
tree1434be86606ac0eec55f65b09bd7a7c4c49c5d7c
parent- update to 1.3.29+1.55 (diff)
- Update to 1.99
This release reuires an useless dependency on libdbi (since dbi support is not complete). I'll try to make this ports libdbi-free soon.
-rw-r--r--www/mod_log_sql2/Makefile5
-rw-r--r--www/mod_log_sql2/distinfo4
-rw-r--r--www/mod_log_sql2/files/patch-mod_log_sql.c31
3 files changed, 6 insertions, 34 deletions
diff --git a/www/mod_log_sql2/Makefile b/www/mod_log_sql2/Makefile
index 3e4395445289..50b4645ff425 100644
--- a/www/mod_log_sql2/Makefile
+++ b/www/mod_log_sql2/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= mod_log_sql
-PORTVERSION= 1.97
+PORTVERSION= 1.99
CATEGORIES= www databases
MASTER_SITES= http://www.outoforder.cc/downloads/${PORTNAME}/
@@ -20,6 +20,9 @@ USE_GMAKE= yes
CONFIGURE_ARGS+= --with-apxs=${APXS}
SSL_PLIST= "@comment "
PLIST_SUB+= SSL=${SSL_PLIST}
+CONFIGURE_ARGS+= --with-dbi=${LOCALBASE}
+LIB_DEPENDS+= dbi.0:${PORTSDIR}/databases/libdbi
+CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib -L${LOCALBASE}/lib/mysql"
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/www/apache2/Makefile.modules.3rd"
diff --git a/www/mod_log_sql2/distinfo b/www/mod_log_sql2/distinfo
index 9a6896179eab..2c78a0c99e69 100644
--- a/www/mod_log_sql2/distinfo
+++ b/www/mod_log_sql2/distinfo
@@ -1,2 +1,2 @@
-MD5 (mod_log_sql-1.97.tar.gz) = 6e5616dbb6eec5e1acd2d3fd8b42e5be
-SIZE (mod_log_sql-1.97.tar.gz) = 148593
+MD5 (mod_log_sql-1.99.tar.gz) = e246a3d8e96d2d62715eb34f75c7c11d
+SIZE (mod_log_sql-1.99.tar.gz) = 159167
diff --git a/www/mod_log_sql2/files/patch-mod_log_sql.c b/www/mod_log_sql2/files/patch-mod_log_sql.c
deleted file mode 100644
index 4b58535863f1..000000000000
--- a/www/mod_log_sql2/files/patch-mod_log_sql.c
+++ /dev/null
@@ -1,31 +0,0 @@
---- mod_log_sql.c.orig Fri Apr 16 14:47:38 2004
-+++ mod_log_sql.c Fri Apr 16 14:47:51 2004
-@@ -1,5 +1,13 @@
- /* $Id: mod_log_sql.c,v 1.20 2004/03/05 00:30:58 urkle Exp $ */
-
-+#if defined(WITH_APACHE20)
-+# include "apache20.h"
-+#elif defined(WITH_APACHE13)
-+# include "apache13.h"
-+#else
-+# error Unsupported Apache version
-+#endif
-+
- #ifdef HAVE_CONFIG_H
- /* Undefine these to prevent conflicts between Apache ap_config_auto.h and
- * my config.h. Only really needed for Apache < 2.0.48, but it can't hurt.
-@@ -11,14 +19,6 @@
- #undef PACKAGE_VERSION
-
- #include "config.h"
--#endif
--
--#if defined(WITH_APACHE20)
--# include "apache20.h"
--#elif defined(WITH_APACHE13)
--# include "apache13.h"
--#else
--# error Unsupported Apache version
- #endif
-
- #if APR_HAVE_UNISTD_H