summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2008-05-04 16:02:35 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2008-05-04 16:02:35 +0000
commit6c3defd24fbb75aee9b29fe141199ca295f8ac54 (patch)
tree8c0282dadda12f3179cc0aab4c14a03b672a1448
parent- Update to 1.3.15. (diff)
- use gtk20 and make it default
- drop option VICE_WITH_GNOME - new option VICE_WITHOUT_GNOME for lite package, will build with Xaw (not3d) - new option VICE_WITH_XAW3D for classic package, will build with Xaw3d
-rw-r--r--emulators/vice/Makefile20
1 files changed, 13 insertions, 7 deletions
diff --git a/emulators/vice/Makefile b/emulators/vice/Makefile
index 2e0f7a723ca0..6a01b766d8a3 100644
--- a/emulators/vice/Makefile
+++ b/emulators/vice/Makefile
@@ -6,7 +6,7 @@
PORTNAME= vice
PORTVERSION= 1.22
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= emulators
MASTER_SITES= http://www.viceteam.org/online/ \
http://www.zimmers.net/anonftp/pub/cbm/crossplatform/emulators/VICE/ \
@@ -20,7 +20,7 @@ BUILD_DEPENDS= bdftopcf:${PORTSDIR}/x11-fonts/bdftopcf \
mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir \
mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale
LIB_DEPENDS= png:${PORTSDIR}/graphics/png
-.if !defined(VICE_WITH_GNOME)
+.if defined(VICE_WITH_XAW3D)
LIB_DEPENDS+= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
.endif
@@ -31,14 +31,20 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
MAKE_ENV+= MAKEINFOFLAGS="--no-split"
-.if defined(VICE_WITH_GNOME)
+.if defined(VICE_WITH_XAW3D)
+GNOME_SUFFIX= -xaw3d
+CONFIGURE_ARGS= --with-xaw3d --disable-gnomeui
+CONFLICTS?= vice-gnome-1.* vice-1.*
+.else
+.if !defined(VICE_WITHOUT_GNOME)
GNOME_SUFFIX= -gnome
-USE_GNOME= gnomelibs libgnomeui
+USE_GNOME= gtk20
CONFIGURE_ARGS= --enable-gnomeui
-CONFLICTS?= vice-1.*
+CONFLICTS?= vice-1.* vice-xaw3d-1.*
.else
-CONFIGURE_ARGS= --with-xaw3d
-CONFLICTS?= vice-gnome-1.*
+CONFIGURE_ARGS= --without-xaw3d --disable-gnomeui
+CONFLICTS?= vice-xaw3d-1.* vice-gnome-1.*
+.endif
.endif
CFLAGS+= -I${LOCALBASE}/include