summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-05-05 14:59:21 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-05-05 14:59:21 +0000
commit665867f4fdaed304bae9e560f48fc4507afb16b4 (patch)
tree05e509f1793ea7d1082335e794104e4f63eb4f0b
parent Update to 3.1 (diff)
Add tclxml-expat , API for parsing XML documents using Tcl.
TclXML is an API for parsing XML documents using the Tcl scripting language. It is also a package with several parser implementations. The goal of the TclXML package is to provide an API for Tcl scripts that allows "Plug-and-Play" parser implementations; ie. an application will be able to use different parser implementations without change to the application code.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/tclxml-expat/Makefile23
-rw-r--r--devel/tclxml-expat/pkg-descr9
-rw-r--r--devel/tclxml-expat/pkg-plist6
4 files changed, 39 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 1405c5a69dc4..1bd22ca905c3 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2377,6 +2377,7 @@
SUBDIR += tclthread
SUBDIR += tcltls
SUBDIR += tclxml
+ SUBDIR += tclxml-expat
SUBDIR += tdl
SUBDIR += templ
SUBDIR += terminality
diff --git a/devel/tclxml-expat/Makefile b/devel/tclxml-expat/Makefile
new file mode 100644
index 000000000000..1439bc6956cf
--- /dev/null
+++ b/devel/tclxml-expat/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: tclxml-expat
+# Date created: 28 April 2008
+# Whom: Frank Fenor
+#
+# $FreeBSD$
+#
+
+PKGNAMESUFFIX= -expat
+
+MAINTAINER= frank@fenor.de
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/TclxmlConfig.sh:${PORTSDIR}/devel/tclxml
+
+USE_LDCONFIG= ${LOCALBASE}/lib/Tclexpat${PORTVERSION}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/expat
+LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
+CONFIGURE_ENV+= CFLAGS="${CFLAGS} -I${LOCALBASE}/include"
+
+MASTERDIR= ${.CURDIR}/../tclxml
+
+BUILDING_EXPAT= yes
+
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/tclxml-expat/pkg-descr b/devel/tclxml-expat/pkg-descr
new file mode 100644
index 000000000000..d87e45fbabfc
--- /dev/null
+++ b/devel/tclxml-expat/pkg-descr
@@ -0,0 +1,9 @@
+tclxml-expat
+TclXML is an API for parsing XML documents using the Tcl scripting
+language. It is also a package with several parser implementations.
+The goal of the TclXML package is to provide an API for Tcl scripts
+that allows "Plug-and-Play" parser implementations; ie. an application
+will be able to use different parser implementations without change
+to the application code.
+
+WWW: http://tclxml.sourceforge.net/
diff --git a/devel/tclxml-expat/pkg-plist b/devel/tclxml-expat/pkg-plist
new file mode 100644
index 000000000000..28147b65b358
--- /dev/null
+++ b/devel/tclxml-expat/pkg-plist
@@ -0,0 +1,6 @@
+include/xmlparse.h
+include/xmlrole.h
+include/xmltok.h
+lib/Tclexpat%%VER%%/libTclexpat%%VER%%.so
+lib/Tclexpat%%VER%%/pkgIndex.tcl
+@dirrm lib/Tclexpat3.1